diff mbox series

[bug#68518] gnu: Add go-github-com-gregjones-httpcache.

Message ID 87zfx5t21j.fsf@gmail.com
State New
Headers show
Series [bug#68518] gnu: Add go-github-com-gregjones-httpcache. | expand

Commit Message

Artyom V. Poptsov Jan. 16, 2024, 9:13 p.m. UTC
Hello,

this patch adds "go-github-com-gregjones-httpcache".
- avp

Comments

Sharlatan Hellseher Jan. 22, 2024, 7:41 p.m. UTC | #1
Hi,

This project is archived and read-only on GitGub. Is it required for
some other package to be updated?

Thanks,
Oleg
Artyom V. Poptsov Feb. 1, 2024, 7:48 p.m. UTC | #2
Hello,

I have some troubles with receiving some emails on my Gmail account from
debbugs recently, but I've got response on the patch from Sharlatan
Hellseher:

> Hi,
>
> This project is archived and read-only on GitGub. Is it required for
> some other package to be updated?
>
> Thanks,
> Oleg

Thanks for reviewing my patch!  Yes, the project is archived by its
author, but in the "README" you can read[1] the following statement:

--8<---------------cut here---------------start------------->8---
This project isn't actively maintained; it works for what I, and
seemingly others, want to do with it, and I consider it "done". That
said, if you find any issues, please open a Pull Request and I will try
to review it. Any changes now that change the public API won't be
considered.
--8<---------------cut here---------------end--------------->8---

The graph[2] of the dependents for "httpcache" is quite big; it lists
some popular packages including[3] "Chezmoi" package.

So in my opinion it is worthwhile to package "httpcache" as it will help
to package/update the future packages.

Thanks,
- avp

References:
1. https://github.com/gregjones/httpcache
2. https://github.com/gregjones/httpcache/network/dependents
3. https://github.com/twpayne/chezmoi/blob/v2.46.0/go.mod#L26
Sharlatan Hellseher Feb. 2, 2024, 5:01 p.m. UTC | #3
Hi,

The Chezmoi package is broken for a long time thank you for attempt to
update and fix it!

Placing some findings related to Chezmoi issue which are still not
touched.

- https://issues.guix.gnu.org/50037 Aug 2021 [PATCH 1/2] gnu:
  go-github-com-zalando-go-keyring: Update to 0.1.1.
- https://issues.guix.gnu.org/50035 Aug 2021 [PATCH 1/3] gnu:
  go-github-com-godbus-dbus: Update to 5.0.4.

Pushed as 34e8a40dadc1169d4810fa5111a9eaaadedeb66f to master.

Thanks,
Oleg
diff mbox series

Patch

From 1f9c6c060e528df83b0f0dc2e816828da130d3af Mon Sep 17 00:00:00 2001
Message-ID: <1f9c6c060e528df83b0f0dc2e816828da130d3af.1705439507.git.poptsov.artyom@gmail.com>
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Wed, 17 Jan 2024 00:07:42 +0300
Subject: [PATCH] gnu: Add go-github-com-gregjones-httpcache.

* gnu/packages/golang-web.scm (go-github-com-gregjones-httpcache): New
  variable.

Change-Id: I2ba0196fd1de63f26a814dc96ff64a6fb5379043
---
 gnu/packages/golang-web.scm | 30 +++++++++++++++++++++++++++++-
 1 file changed, 29 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 3e60bfaf33..fd9384d060 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -21,7 +21,7 @@ 
 ;;; Copyright © 2023 Hilton Chain <hako@ultrarare.space>
 ;;; Copyright © 2023 Katherine Cox-Buday <cox.katherine.e@gmail.com>
 ;;; Copyright © 2023 Nicolas Graves <ngraves@ngraves.fr>
-;;; Copyright © 2023 Artyom V. Poptsov <poptsov.artyom@gmail.com>
+;;; Copyright © 2023, 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -868,6 +868,34 @@  (define-public go-github-com-gorilla-websocket
 protocol.")
     (license license:bsd-2)))
 
+(define-public go-github-com-gregjones-httpcache
+  (let ((commit "901d90724c7919163f472a9812253fb26761123d")
+        (revision "0"))
+    (package
+      (name "go-github-com-gregjones-httpcache")
+      (version (git-version "0.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/gregjones/httpcache")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "05r0xq51vfb55di11m7iv19341d73f7in33vq1ihcqs1nffdwiq0"))))
+      (build-system go-build-system)
+      (arguments
+       '(#:import-path "github.com/gregjones/httpcache"))
+      (synopsis "Transport for @code{http.Client} that will cache responses")
+      (description
+       "Package @code{httpcache} provides a @code{http.RoundTripper}
+implementation that works as a mostly @url{https://tools.ietf.org/html/rfc7234, RFC
+7234} compliant cache for HTTP responses.  It is only suitable for use as a
+\"private\" cache (i.e. for a web-browser or an API-client and not for a shared
+proxy).")
+      (home-page "https://github.com/gregjones/httpcache")
+      (license license:expat))))
+
 (define-public go-github-com-hjson-hjson-go
   (package
     (name "go-github-com-hjson-hjson-go")

base-commit: 171ac4fa4f5e5dd2f2e110487de5d41b5b79a564
-- 
2.41.0