diff mbox series

[bug#69047,v2] gnu: go-github-com-oneofone-xxhash: Remove benchmarks.

Message ID 87zfw5bcco.fsf@troyfigiel.com
State New
Headers show
Series [bug#69047,v2] gnu: go-github-com-oneofone-xxhash: Remove benchmarks. | expand

Commit Message

Troy Figiel Feb. 11, 2024, 11:17 a.m. UTC
* gnu/packages/golang.scm (go-github-com-oneofone-xxhash): Remove benchmarks.
[arguments]<#:phases>: Add remove-benchmarks phase.
---
 gnu/packages/golang.scm | 8 +++++++-
 1 file changed, 7 insertions(+), 1 deletion(-)


base-commit: 16d2be641424815a1779119bb64bc6ba1be1161b
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 163691a1e6..2d52dbaa19 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10228,7 +10228,13 @@  (define-public go-github-com-oneofone-xxhash
          "0f98qk83l2fhpclvrgyxsa9b8m4pipf11fah85bnjl01wy4lvybw"))))
     (build-system go-build-system)
     (arguments
-     '(#:import-path "github.com/OneOfOne/xxhash"))
+     (list
+      #:import-path "github.com/OneOfOne/xxhash"
+      #:phases #~(modify-phases %standard-phases
+                   (add-after 'unpack 'remove-benchmarks
+                     (lambda* (#:key import-path #:allow-other-keys)
+                       (delete-file-recursively
+                        (string-append "src/" import-path "/benchmarks")))))))
     (home-page "https://github.com/OneOfOne/xxhash")
     (synopsis "Go implementation of xxHash")
     (description "This is a native Go implementation of the