diff mbox series

[bug#69181] gnu: Add go-github-com-benbjohnson-clock.

Message ID 87zfvx3g0g.fsf@gmail.com
State New
Headers show
Series [bug#69181] gnu: Add go-github-com-benbjohnson-clock. | expand

Commit Message

Artyom V. Poptsov Feb. 18, 2024, 4:15 p.m. UTC
Hello,

this patch adds "go-github-com-benbjohnson-clock" package. [1]

Although the project is archived on GitHub it is required for the Kubo
(IPFS) package since version 0.20.0 up to 0.26.0 (which is the latest
version.) [2]
Thanks,
- avp

References:
1. https://github.com/benbjohnson/clock
2. https://github.com/ipfs/kubo/blob/096f510ab206c119693f145bc3331eeb33a69e07/go.mod#L6

Comments

Sharlatan Hellseher Feb. 20, 2024, 12:02 a.m. UTC | #1
Hi,

Pushed as 084ce22aa336cc92104d586ede30b583fb9e6fef to master.

--
Oleg
diff mbox series

Patch

From 27c42ddecac1ead31a194503144cda2e1a8cd3e2 Mon Sep 17 00:00:00 2001
Message-ID: <27c42ddecac1ead31a194503144cda2e1a8cd3e2.1708179999.git.poptsov.artyom@gmail.com>
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Sat, 17 Feb 2024 17:24:33 +0300
Subject: [PATCH] gnu: Add go-github-com-benbjohnson-clock.

* gnu/packages/golang-xyz.scm (go-github-com-benbjohnson-clock): New variable.

Change-Id: Ifcb3254e07388a6c7b4a7f9ee5dff4f3b4d25ee8
---
 gnu/packages/golang-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index b0a5955405..716b199951 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -146,6 +146,31 @@  (define-public go-github-com-armon-go-radix
 @url{http://en.wikipedia.org/wiki/Radix_tree,radix tree}.")
     (license license:expat)))
 
+(define-public go-github-com-benbjohnson-clock
+  (package
+    (name "go-github-com-benbjohnson-clock")
+    (version "1.3.5")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/benbjohnson/clock")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1p7n09pywqra21l981fbkma9vzsyf31pbvw6xg5r4hp8h8scf955"))))
+    (build-system go-build-system)
+    (arguments
+     `(#:import-path "github.com/benbjohnson/clock"
+       #:go ,go-1.21))
+    (home-page "https://github.com/benbjohnson/clock")
+    (synopsis "Small library for mocking time in Go")
+    (description
+     "@code{clock} is a small library for mocking time in Go.  It provides an
+interface around the standard library's @code{time} package so that the application
+can use the realtime clock while tests can use the mock clock.")
+    (license license:expat)))
+
 (define-public go-github-com-bitly-go-hostpool
   (package
     (name "go-github-com-bitly-go-hostpool")

base-commit: 3cf199dbcf85a44fa8370e786e568fc3feb7067c
-- 
2.41.0