[bug#77269] Add jellyfin-media-player package

Message ID 87zfgzqbwe.fsf@gmail.com
State New
Headers
Series [bug#77269] Add jellyfin-media-player package |

Commit Message

Apoorv Singh April 2, 2025, 7:07 a.m. UTC
  Here is the updated patch for jellyfin-media-player.

--
- Apoorv Singh
- Sent from Emacs.
  

Patch

From 9fd4a6013f76aa50b910d74d4dd66b4be19cd066 Mon Sep 17 00:00:00 2001
From: apoorv569 <apoorvs569@gmail.com>
Date: Wed, 26 Mar 2025 10:14:51 +0530
Subject: [PATCH] Add jellyfin-media-player package

---
 gnu/packages/video.scm | 50 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 50 insertions(+)

diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 0ddfc022a9..c9fa5a0e37 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -297,6 +297,56 @@  (define (bin command)
 user has installed.")
     (license license:gpl3+)))
 
+(define-public jellyfin-media-player
+  (let ((commit "68ddf01ecef766620d4e564cada0a1125840547f")
+        (revision "0"))
+    (package
+     (name "jellyfin-media-player")
+     (version (git-version "1.12.0" revision commit))
+     (source
+      (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/jellyfin/jellyfin-media-player")
+             (commit commit)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0552z343i49nnhw08bifncvgs1cm4zccqwk7g9jy6gnjncs441il"))))
+     (inputs (list alsa-lib
+                   freetype
+                   fribidi
+                   harfbuzz
+                   libvdpau
+                   libx11
+                   libxrandr
+                   mesa
+                   mpv
+                   qtbase-5
+                   qtdeclarative-5
+                   qtgraphicaleffects
+                   qtquickcontrols-5
+                   qtquickcontrols2-5
+                   qtx11extras
+                   qtwebchannel-5
+                   qtwebengine-5
+                   sdl2
+                   uchardet))
+     (native-inputs (list pkg-config
+                          python))
+     (build-system qt-build-system)
+     (arguments
+      (list
+       #:tests? #f ;No test target available
+       #:build-type "Release"))
+     (home-page "https://jellyfin.org")
+     (synopsis "Desktop client for Jellyfin, a media streaming server.")
+     (description "Jellyfin is a server for managing and stream media.
+This desktop client uses jellyfin-web with an embedded MPV player.
+It supports Windows, macOS, and Linux. Media plays within the same
+window using the jellyfin-web interface, unlike Jellyfin Desktop.
+It also supports audio passthrough.")
+     (license license:gpl2))))
+
 (define-public transcode
   (package
     (name "transcode")
-- 
2.49.0