diff mbox series

bug#36197: [Patch] gnu: add celestia; celestia-gtk

Message ID 87y31oik6m.fsf@gnu.org
State Accepted
Headers show
Series bug#36197: [Patch] gnu: add celestia; celestia-gtk | expand

Commit Message

Ludovic Courtès June 26, 2019, 12:51 p.m. UTC
Hi Amar,

Amar Singh <nly@disroot.org> skribis:

>>From dba590074e9a0c7cf3dc8440492190de732feaea Mon Sep 17 00:00:00 2001
> From: Amar Singh <nly@disroot.org>
> Date: Sun, 19 May 2019 12:39:48 +0530
> Subject: [PATCH 1/2] gnu: Add celestia.
>
> * gnu/packages/astronomy.scm (celestia): New variable.

I fixed the license as swedebugia noted, made the minor cosmetic changes
shown below, and applied.

>>From c8dd3c6871da910761ea8908f6bc9866c7f3c5ac Mon Sep 17 00:00:00 2001
> From: Amar Singh <nly@disroot.org>
> Date: Thu, 13 Jun 2019 22:53:22 +0530
> Subject: [PATCH 2/2] gnu: Add celestia-gtk.
>
> * gnu/packages/astronomy.scm (celestia-gtk): New variable.

Applied with the changes below.

Thank you!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index df801ef444..81c7481e0b 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -42,7 +42,8 @@ 
   #:use-module (gnu packages gnome)
   #:use-module (gnu packages maths)
   #:use-module (guix build-system cmake)
-  #:use-module (guix build-system gnu))
+  #:use-module (guix build-system gnu)
+  #:use-module (srfi srfi-1))
 
 (define-public cfitsio
   (package
@@ -238,15 +239,13 @@  accurately in real time at any rate desired.")
       (license license:gpl2+))))
 
 (define-public celestia-gtk
-  (package (inherit celestia)
-           (name "celestia-gtk")
-           (version (package-version celestia))
-           (inputs
-            (append (filter (lambda (x)
-                              (not (equal? (car x) "freeglut")))
-                            (package-inputs celestia))
-                    `(("gtk2" ,gtk+-2)
-                      ("gtkglext" ,gtkglext))))
-           (arguments
-            `(#:configure-flags '("-DENABLE_GTK=ON" "-DENABLE_QT=OFF")
-              #:tests? #f))))
+  (package
+    (inherit celestia)
+    (name "celestia-gtk")
+    (inputs
+     (append (alist-delete "freeglut" (package-inputs celestia))
+             `(("gtk2" ,gtk+-2)
+               ("gtkglext" ,gtkglext))))
+    (arguments
+     `(#:configure-flags '("-DENABLE_GTK=ON" "-DENABLE_QT=OFF")
+       #:tests? #f))))