From 08efecbbd181cc7db0c008b9740bc95ea2f78472 Mon Sep 17 00:00:00 2001
From: Alex ter Weele <alex.ter.weele@gmail.com>
Date: Sat, 7 Sep 2019 16:18:38 -0500
Subject: [PATCH] gnu: Add fennel.
* gnu/packages/fennel.scm: New file.
* gnu/local.mk (GNU_SYSTEM_MODULES): Add fennel.scm.
---
gnu/local.mk | 1 +
gnu/packages/fennel.scm | 62 +++++++++++++++++++++++++++++++++++++++++
2 files changed, 63 insertions(+)
create mode 100644 gnu/packages/fennel.scm
@@ -176,6 +176,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/erlang.scm \
%D%/packages/fabric-management.scm \
%D%/packages/fcitx.scm \
+ %D%/packages/fennel.scm \
%D%/packages/figlet.scm \
%D%/packages/file.scm \
%D%/packages/file-systems.scm \
new file mode 100644
@@ -0,0 +1,62 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2019 Alex ter Weele <alex.ter.weele@gmail.com>
+
+(define-module (gnu packages fennel)
+ #:use-module (gnu packages lua)
+ #:use-module (guix packages)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix git-download)
+ #:use-module ((guix licenses) #:prefix license:))
+
+(define-public fennel
+ (package
+ (name "fennel")
+ (version "0.2.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/bakpakin/Fennel.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1yn2lyfcrsjcx60lxy0xcyl2rfk4r5pydbkcblpikpk6vhr10ws0"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:test-target "test"
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (delete 'build)
+ (replace 'install
+ (lambda _
+ (let* ((out (assoc-ref %outputs "out"))
+ (data (string-append out "/share/"))
+ (bin (string-append out "/bin/")))
+ (copy-recursively (assoc-ref %build-inputs "source") data)
+ (install-file "fennel" bin)
+ (wrap-program (string-append bin "fennel")
+ `("LUA_PATH" ":" prefix (,(string-append data "?.lua"))))))))))
+ (inputs
+ `(("lua" ,lua)))
+ (home-page "https://fennel-lang.org/")
+ (synopsis "Lua lisp language")
+ (description "Fennel is a programming language that brings together the
+speed, simplicity, and reach of Lua with the flexibility of a lisp syntax and
+macro system.
+
+ * Full Lua compatibility: Easily call any Lua function or library from
+Fennel and vice-versa.
+
+ * Zero overhead: Compiled code should be just as or more efficient than
+hand-written Lua.
+
+ * Compile-time macros: Ship compiled code with no runtime dependency on
+Fennel.
+
+ * Embeddable: Fennel is a one-file library as well as an executable.
+Embed it in other programs to support runtime extensibility and interactive
+development.
+
+Anywhere you can run Lua code, you can run Fennel code.")
+ (license license:x11)))
--
2.23.0