diff mbox series

[bug#37661] gnu: python2-tqdm: Depend on python2-functools32.

Message ID 87y2xvnxta.fsf@gmx.com
State Accepted
Headers show
Series [bug#37661] gnu: python2-tqdm: Depend on python2-functools32. | expand

Commit Message

Pierre Langlois Oct. 8, 2019, 1:58 p.m. UTC
Hi Guix!

This fixes the python2-tqdm package which failed to build for me since
core-updates was merged:

```
starting phase `check'
running "python setup.py" with command "test" and parameters ()
running test
Searching for functools32
Reading https://pypi.org/simple/functools32/
Download error on https://pypi.org/simple/functools32/: [Errno -2] Name or service not known -- Some packages may not be found!
Couldn't find index page for 'functools32' (maybe misspelled?)
Scanning index of all packages (this may take a while)
Reading https://pypi.org/simple/
Download error on https://pypi.org/simple/: [Errno -2] Name or service not known -- Some packages may not be found!
No local packages or working download links found for functools32
error: Could not find suitable distribution for Requirement.parse('functools32')
command "python" "-c" "import setuptools, tokenize;__file__='setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\\r\\n', '\\n');f.close();exec(compile(code, __file__, 'exec'))" "test" failed with status 1
builder for `/gnu/store/p3v9nnxsk9bl0lxcd2zfzkgx56sv1q11-python2-tqdm-4.19.6.drv' failed with exit code 1
build of /gnu/store/p3v9nnxsk9bl0lxcd2zfzkgx56sv1q11-python2-tqdm-4.19.6.drv failed
View build log at '/var/log/guix/drvs/p3/v9nnxsk9bl0lxcd2zfzkgx56sv1q11-python2-tqdm-4.19.6.drv.bz2'.
guix build: error: build of `/gnu/store/p3v9nnxsk9bl0lxcd2zfzkgx56sv1q11-python2-tqdm-4.19.6.drv' failed
```

Adding python2-functools32 as a native-input fixes the issue.
Thanks,
Pierre

Comments

Marius Bakke Oct. 8, 2019, 9:19 p.m. UTC | #1
Pierre Langlois <pierre.langlois@gmx.com> writes:

> Hi Guix!
>
> This fixes the python2-tqdm package which failed to build for me since
> core-updates was merged:
>
> ```
> starting phase `check'
> running "python setup.py" with command "test" and parameters ()
> running test
> Searching for functools32
> Reading https://pypi.org/simple/functools32/
> Download error on https://pypi.org/simple/functools32/: [Errno -2] Name or service not known -- Some packages may not be found!
> Couldn't find index page for 'functools32' (maybe misspelled?)
> Scanning index of all packages (this may take a while)
> Reading https://pypi.org/simple/
> Download error on https://pypi.org/simple/: [Errno -2] Name or service not known -- Some packages may not be found!
> No local packages or working download links found for functools32
> error: Could not find suitable distribution for Requirement.parse('functools32')
> command "python" "-c" "import setuptools, tokenize;__file__='setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\\r\\n', '\\n');f.close();exec(compile(code, __file__, 'exec'))" "test" failed with status 1
> builder for `/gnu/store/p3v9nnxsk9bl0lxcd2zfzkgx56sv1q11-python2-tqdm-4.19.6.drv' failed with exit code 1
> build of /gnu/store/p3v9nnxsk9bl0lxcd2zfzkgx56sv1q11-python2-tqdm-4.19.6.drv failed
> View build log at '/var/log/guix/drvs/p3/v9nnxsk9bl0lxcd2zfzkgx56sv1q11-python2-tqdm-4.19.6.drv.bz2'.
> guix build: error: build of `/gnu/store/p3v9nnxsk9bl0lxcd2zfzkgx56sv1q11-python2-tqdm-4.19.6.drv' failed
> ```
>
> Adding python2-functools32 as a native-input fixes the issue.

Thanks!  Pushed in f875d76f16.
diff mbox series

Patch

From 13a97fe6bda3aee5bc61a0d0de3459069bc947e1 Mon Sep 17 00:00:00 2001
From: Pierre Langlois <pierre.langlois@gmx.com>
Date: Tue, 8 Oct 2019 14:38:32 +0100
Subject: [PATCH] gnu: python2-tqdm: Depend on python2-functools32.

* gnu/packages/python-xyz.scm (python-tqdm)[properties]: Add python2-variant.
(python2-tqdm): Use 'strip-python2-variant'.
[native-inputs]: Add python2-functools32.
---
 gnu/packages/python-xyz.scm | 9 +++++++--
 1 file changed, 7 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b0f5ec7588..c30532266c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13746,10 +13746,15 @@  ignoring formatting changes.")
       "Make loops show a progress bar on the console by just wrapping any
 iterable with @code{|tqdm(iterable)|}.  Offers many options to define
 design and layout.")
-    (license (list license:mpl2.0 license:expat))))
+    (license (list license:mpl2.0 license:expat))
+    (properties `((python2-variant . ,(delay python2-tqdm))))))

 (define-public python2-tqdm
-  (package-with-python2 python-tqdm))
+  (let ((tqdm (package-with-python2
+                (strip-python2-variant python-tqdm))))
+    (package (inherit tqdm)
+      (native-inputs `(("python2-functools32" ,python2-functools32)
+                        ,@(package-native-inputs tqdm))))))

 (define-public python-pkginfo
   (package
--
2.23.0