diff mbox series

[bug#37670] gnu: Add emacs-ssh-agency.

Message ID 87y2xuya5t.fsf@lafreniere.xyz
State Accepted
Headers show
Series [bug#37670] gnu: Add emacs-ssh-agency. | expand

Commit Message

LaFreniere, Joseph Oct. 9, 2019, 1:34 a.m. UTC
Please find the patch attached.

--
Joseph LaFreniere

Comments

Kyle Meyer Oct. 9, 2019, 2:06 a.m. UTC | #1
Hi Joseph,

"LaFreniere\, Joseph" <joseph@lafreniere.xyz> writes:

> +     "This package provides functions to startup @code{ssh-agent}, set the
> +needed environment variables in Emacs, prompt for passphrases from within
> +Emacs, and so that pushes and pulls from @code{magit} will not require
> +entering any passphrase.

I think the "and" before "so" should be moved before "prompt".

LGTM otherwise.  Thanks.
Brian Leung Oct. 9, 2019, 7:13 p.m. UTC | #2
Merged, thanks.
diff mbox series

Patch

From 9060255351353a2933d236992654c9dea52b026a Mon Sep 17 00:00:00 2001
From: Joseph LaFreniere <joseph@lafreniere.xyz>
Date: Sun, 25 Aug 2019 15:38:42 -0500
Subject: [PATCH] gnu: Add emacs-ssh-agency.

* gnu/packages/emacs-xyz.scm (emacs-ssh-agency): New variable.
---
 gnu/packages/emacs-xyz.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 1b8ae47fc2..5a68f6417c 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -18741,6 +18741,34 @@  JIRA issue servers.")
 keybindings for skipping from host section to host section.")
       (license license:gpl3+))))
 
+(define-public emacs-ssh-agency
+  (package
+    (name "emacs-ssh-agency")
+    (version "0.4")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/magit/ssh-agency.git")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0895n7bss4wdydic1gflr03f2cwdyqywl16gvb599lpn288jhwvz"))))
+    (build-system emacs-build-system)
+    (propagated-inputs
+     `(("dash" ,emacs-dash)))
+    (home-page "https://github.com/magit/ssh-agency")
+    (synopsis "Manage @code{ssh-agent} from Emacs")
+    (description
+     "This package provides functions to startup @code{ssh-agent}, set the
+needed environment variables in Emacs, prompt for passphrases from within
+Emacs, and so that pushes and pulls from @code{magit} will not require
+entering any passphrase.
+
+It can also be useful on Unix-like platforms to delay having to enter your
+passphrase until the first time you push to a remote.")
+    (license license:gpl3+)))
+
 (define-public emacs-tao-theme
   (let ((commit "c5107fbe7e752f4e58c2d2147ff18a1ebb12937c")
         (revision "0"))
-- 
2.22.0