diff mbox series

[bug#38488,1/2] gnu: Add ghc-sendfile.

Message ID 87y2vspms0.fsf@posteo.net
State Accepted
Headers show
Series [bug#38488,1/2] gnu: Add ghc-sendfile. | expand

Commit Message

Brett Gilio Dec. 4, 2019, 7:34 a.m. UTC

diff mbox series

Patch

From bef2ec92972c3fbef7558edc9d9ba37d7ca98d68 Mon Sep 17 00:00:00 2001
From: Brett Gilio <brettg@posteo.net>
Date: Wed, 4 Dec 2019 01:29:20 -0600
Subject: [PATCH 1/2] gnu: Add ghc-sendfile.

* gnu/packages/haskell-web.scm (ghc-sendfile): New variable.
---
 gnu/packages/haskell-web.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)

diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index 1672170131..6098ad5759 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -1527,3 +1527,24 @@  The first three components of the version number match the upstream flot
 version.  The package is designed to meet the redistribution
 requirements of downstream users (e.g. Debian).")
     (license license:expat)))
+(define-public ghc-sendfile
+  (package
+    (name "ghc-sendfile")
+    (version "0.7.11.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://hackage.haskell.org/package/sendfile/sendfile-"
+             version ".tar.gz"))
+       (sha256
+        (base32
+         "0988snmx3bylpw3kcq8hsgji8idc6xcrcfp275qjv3apfdgc9rp0"))))
+    (build-system haskell-build-system)
+    (inputs `(("ghc-network" ,ghc-network)))
+    (home-page
+     "https://hub.darcs.net/stepcut/sendfile")
+    (synopsis "Portable sendfile library for Haskell")
+    (description
+     "Haskell library which exposes zero-copy sendfile functionality in a portable way.")
+    (license license:bsd-3)))
-- 
2.24.0