diff mbox series

[bug#40306] gnu: Add xwallpaper

Message ID 87y2rk0wpf.fsf@asu.edu
State Accepted
Headers show
Series [bug#40306] gnu: Add xwallpaper | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

John Soo March 29, 2020, 1:35 a.m. UTC
Hi Guix,

xwallpaper is a small wallpapering program. It is like feh and quite
handy if you use a window manager.

Thanks,

John

Comments

Marius Bakke April 2, 2020, 4:51 p.m. UTC | #1
John Soo <jsoo1@asu.edu> writes:

> Hi Guix,
>
> xwallpaper is a small wallpapering program. It is like feh and quite
> handy if you use a window manager.

Thanks!  I moved it to xdisorg.scm as that seemed more appropriate.  I
also added a copyright line for you, and fixed the indentation.

After doing so I noticed that 'autoconf' and friends were in 'inputs'
instead of 'native-inputs', so I fixed those too as suggested by 'guix
lint'.  In hindsight I should have bounced it back to you, but oh well.

Applied!
diff mbox series

Patch

>From 486a6ef62aeb401bd80f960f3587187b41997085 Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Fri, 27 Mar 2020 08:31:10 -0700
Subject: [PATCH] gnu: Add xwallpaper.

* gnu/packages/image-viewers.scm (xwallpaper): New variable.
---
 gnu/packages/image-viewers.scm | 35 ++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)

diff --git a/gnu/packages/image-viewers.scm b/gnu/packages/image-viewers.scm
index 8f3f61c4b1..01191b7ef5 100644
--- a/gnu/packages/image-viewers.scm
+++ b/gnu/packages/image-viewers.scm
@@ -596,3 +596,38 @@  with tiling window managers.  Features include:
 @end itemize\n")
     (home-page "https://github.com/eXeC64/imv")
     (license license:expat)))
+
+(define-public xwallpaper
+  (package
+    (name "xwallpaper")
+    (version "0.6.4")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/stoeckmann/xwallpaper")
+               (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+         (base32
+          "175fzifvia58vah2x7509drvfn3xfv5d9szgh9x1w1a1w8rcs2hx"))))
+    (build-system gnu-build-system)
+    (inputs
+     `(("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("libjpeg-turbo" ,libjpeg-turbo)
+       ("libpng" ,libpng)
+       ("libxpm" ,libxpm)
+       ("pixman" ,pixman)
+       ("pkg-config" ,pkg-config)
+       ("xcb-util" ,xcb-util)
+       ("xcb-util-image" ,xcb-util-image)))
+    (home-page "https://github.com/stoeckmann/xwallpaper")
+    (synopsis "Wallpaper setting utility for X")
+    (description
+     "The xwallpaper utility allows you to set image files as your X
+wallpaper. JPEG, PNG, and XPM file formats are supported.
+
+The wallpaper is also advertised to programs which support semi-transparent
+backgrounds.")
+    (license license:isc)))
-- 
2.26.0