diff mbox series

bug#44738: [PATCH] gnu: Add emacs-next-pgtk

Message ID 87y2inzs09.fsf@gnu.org
State Accepted
Headers show
Series bug#44738: [PATCH] gnu: Add emacs-next-pgtk | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Ludovic Courtès Nov. 26, 2020, 10:13 p.m. UTC
Hi Andrew,

Andrew Tropin <andrew@trop.in> skribis:

> From 168310a375b13081b73ad6ddeb26100bc7bcb61c Mon Sep 17 00:00:00 2001
> From: Andrew Tropin <andrew@trop.in>
> Date: Thu, 19 Nov 2020 17:36:11 +0300
> Subject: [PATCH] gnu: Add emacs-next-pgtk
>
> * gnu/packages/emacs.scm (emacs-next-pgtk): New variable.

As a welcome gift ;-), I applied the following cosmetic changes for you,
most of which were suggested by ‘guix lint’.

Thanks!

Ludo’.

Comments

Andrew Tropin Nov. 27, 2020, 7:12 a.m. UTC | #1
Thanks a lot for improvements and for applying the patch too!

Will setup guix dev environment next week and will start using lint)

On Fri, Nov 27, 2020 at 1:13 AM Ludovic Courtès <ludo@gnu.org> wrote:
>
> Hi Andrew,
>
> Andrew Tropin <andrew@trop.in> skribis:
>
> > From 168310a375b13081b73ad6ddeb26100bc7bcb61c Mon Sep 17 00:00:00 2001
> > From: Andrew Tropin <andrew@trop.in>
> > Date: Thu, 19 Nov 2020 17:36:11 +0300
> > Subject: [PATCH] gnu: Add emacs-next-pgtk
> >
> > * gnu/packages/emacs.scm (emacs-next-pgtk): New variable.
>
> As a welcome gift ;-), I applied the following cosmetic changes for you,
> most of which were suggested by ‘guix lint’.
>
> Thanks!
>
> Ludo’.
>
Ludovic Courtès Nov. 27, 2020, 9:59 a.m. UTC | #2
Andrew Tropin <andrew@trop.in> skribis:

> Thanks a lot for improvements and for applying the patch too!
>
> Will setup guix dev environment next week and will start using lint)

Awesome.  You can also take a look at the check list at
<https://guix.gnu.org/manual/devel/en/html_node/Submitting-Patches.html>.

Thanks,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 957338af5d..6fb323deaf 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -321,31 +321,29 @@  languages.")
       (version (git-version "28.0.50" revision commit))
       (source
        (origin
-	 (method git-fetch)
-	 (uri (git-reference
-	       (url "https://github.com/masm11/emacs")
-	       (commit commit)))
-	 (sha256
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/masm11/emacs")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
           (base32
            "1c677c97b9avhlzysg09cvf6bd69iz41ggppnszw8chhphk3knfc"))))
       (arguments
-       (substitute-keyword-arguments
-	   (package-arguments emacs-next)
-	 ((#:configure-flags flags ''())
-	  `(cons* "--with-pgtk" "--with-xwidgets" ,flags))))
-      (propagated-inputs `(("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
-			   ("glib-networking" ,glib-networking)))
+       (substitute-keyword-arguments (package-arguments emacs-next)
+         ((#:configure-flags flags ''())
+          `(cons* "--with-pgtk" "--with-xwidgets" ,flags))))
+      (propagated-inputs
+       `(("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
+         ("glib-networking" ,glib-networking)))
       (inputs
        `(("webkitgtk" ,webkitgtk)
-	 ,@(package-inputs emacs-next)))
-
+         ,@(package-inputs emacs-next)))
       (home-page "https://github.com/masm11/emacs")
-      (synopsis "The fork of extensible, customizable,
-self-documenting text editor (with pgtk toolkit and xwidgets
-support)")
-      (description "This is an unofficial Emacs fork build with
-pure-gtk to work natively on Wayland. In addition to that xwidgets
-also enabled and work without glitches even on X server."))))
+      (synopsis "Emacs text editor with @code{pgtk} and @code{xwidgets} support")
+      (description "This is an unofficial Emacs fork build with a pure-GTK
+graphical toolkit to work natively on Wayland.  In addition to that, xwidgets
+also enabled and works without glitches even on X server."))))
 
 (define-public emacs-minimal
   ;; This is the version that you should use as an input to packages that just