diff mbox series

[bug#53812] gnu: Add emacs-mct.

Message ID 87y22o8unq.fsf@trop.in
State Accepted
Headers show
Series [bug#53812] gnu: Add emacs-mct. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Andrew Tropin Feb. 5, 2022, 5:19 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-mct): New variable.
---
 gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

Comments

Nicolas Goaziou Feb. 6, 2022, 9:51 p.m. UTC | #1
Hello,

Andrew Tropin <andrew@trop.in> writes:

> * gnu/packages/emacs-xyz.scm (emacs-mct): New variable.

Thank you.

> +(define-public emacs-mct
> +  (package
> +   (name "emacs-mct")
> +   (version "0.4.2")
> +   (source (origin
> +            (method git-fetch)
> +            (uri (git-reference
> +                  (url "https://gitlab.com/protesilaos/mct.git")
> +                  (commit version)))
> +            (sha256
> +             (base32 "0sj9hyxpighspwrm2yimqkdxlhw2yiznaj69ysn2sjd6jn2aqpc6"))
> +            (file-name (git-file-name name version))))
> +   (build-system emacs-build-system)
> +   (license license:gpl3+)
> +   (home-page "https://protesilaos.com/emacs/mct")
> +   (synopsis "Enhancement of the default Emacs minibuffer completion UI.")

Synopsis may not end with a period. You may want to run "guix lint" on
your package definition.

> +   (description "Minibuffer and Completions in Tandem, also known as
> +mct, or mct.el, is a package that enhances the default minibuffer and
> +*Completions* buffer of Emacs 27 (or higher) so that they work
> +together as part of a unified framework. The idea is to make the
> +presentation and overall functionality be consistent with other
> +popular, vertically aligned completion UIs while leveraging built-in
> +functionality.")))

Sentences in description should be separated with two spaces.

Nitpick: license field usually comes last.

Note that upstream mentions this is an Emacs 28+ package, and Guix
provides only Emacs 27.2. Would it be a bit early to provide this
package?

Regards,
Protesilaos Stavrou Feb. 7, 2022, 4:21 a.m. UTC | #2
Hello Nicolas!

On 2022-02-06, 22:51 +0100, Nicolas Goaziou <mail@nicolasgoaziou.fr> wrote:

> Note that upstream mentions this is an Emacs 28+ package, and Guix
> provides only Emacs 27.2. Would it be a bit early to provide this
> package?

This used to be the case in earlier versions, though mct.el specifies
the following since its version 0.3.0:

    ;; Package-Requires: ((emacs "27.1"))
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 444b761116..3e4ea925e1 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -30090,3 +30090,27 @@  (define-public emacs-fennel-mode
      "Fennel mode provides font-lock, indentation, navigation, and REPL for
  Fennel code within Emacs.")
     (license license:gpl3+)))
+
+(define-public emacs-mct
+  (package
+   (name "emacs-mct")
+   (version "0.4.2")
+   (source (origin
+            (method git-fetch)
+            (uri (git-reference
+                  (url "https://gitlab.com/protesilaos/mct.git")
+                  (commit version)))
+            (sha256
+             (base32 "0sj9hyxpighspwrm2yimqkdxlhw2yiznaj69ysn2sjd6jn2aqpc6"))
+            (file-name (git-file-name name version))))
+   (build-system emacs-build-system)
+   (license license:gpl3+)
+   (home-page "https://protesilaos.com/emacs/mct")
+   (synopsis "Enhancement of the default Emacs minibuffer completion UI.")
+   (description "Minibuffer and Completions in Tandem, also known as
+mct, or mct.el, is a package that enhances the default minibuffer and
+*Completions* buffer of Emacs 27 (or higher) so that they work
+together as part of a unified framework. The idea is to make the
+presentation and overall functionality be consistent with other
+popular, vertically aligned completion UIs while leveraging built-in
+functionality.")))