diff mbox series

bug#59336: [PATCH 0/6] gnu: Add apparmor.

Message ID 87y1rmlvir.fsf_-_@gnu.org
State New
Headers show
Series bug#59336: [PATCH 0/6] gnu: Add apparmor. | expand

Commit Message

Ludovic Courtès Dec. 4, 2022, 9:16 p.m. UTC
Hi,

Hilton Chain <hako@ultrarare.space> skribis:

> * gnu/packages/apparmor.scm (pam-apparmor): New variable.

I had to make the following change to get ‘pam-apparmor’ to build.

Applied all of v2 with these changes.  I followed up with a patch to
restrict libapparmor to *-linux systems.

Thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/apparmor.scm b/gnu/packages/apparmor.scm
index 3136091747..ddbd9eb7a9 100644
@@ -188,9 +191,12 @@  (define-public pam-apparmor
         (substitute-keyword-arguments (package-arguments base)
           ((#:phases phases)
            #~(modify-phases #$phases
+               (delete 'chdir-parser)
+               (delete 'chdir-utils)
+               (delete 'chdir-profiles)
                (replace 'change-directory
                  (lambda _
                    (chdir "changehat/pam_apparmor"))))))))
-      (native-inputs (list pkg-config which))
+      (native-inputs (list pkg-config perl which))
       (inputs (list libapparmor linux-pam))
       (license license:bsd-3))))