diff mbox series

[bug#60567] gnu: Add ftxui

Message ID 87y1qblby3.fsf@gmail.com
State New
Headers show
Series [bug#60567] gnu: Add ftxui | expand

Commit Message

Artyom V. Poptsov Jan. 9, 2023, 7:55 p.m. UTC
Hello,

I decided to move the FTXUI package to "cpp.scm" module as the library
provides API mainly for C++ programs.
- Artyom

Comments

Mathieu Othacehe Jan. 10, 2023, 8:16 a.m. UTC | #1
Hell Artyom,

> I decided to move the FTXUI package to "cpp.scm" module as the library
> provides API mainly for C++ programs.

OK, thanks for the v2!

Applied.

Mathieu
Mathieu Othacehe Jan. 10, 2023, 9:55 a.m. UTC | #2
Hey Artyom,

I noticed that the package is failing on non-x86_64 architectures:
https://ci.guix.gnu.org/eval/104402?status=failed.

Could you please have a look?

Thanks,

Mathieu
diff mbox series

Patch

From 74c0a34861242b913ab90ad77af9bdd778562016 Mon Sep 17 00:00:00 2001
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Thu, 5 Jan 2023 08:03:15 +0300
Subject: [PATCH] gnu: Add ftxui.

* gnu/packages/cpp.scm (ftxui): New variable.
---
 gnu/packages/cpp.scm | 49 ++++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 49 insertions(+)

diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index cc594e56c5..23ea05cf9e 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -2343,3 +2343,52 @@  (define-public wdl
 @item And more.
 @end itemize")
       (license license:zlib))))
+
+(define-public ftxui
+  (package
+    (name "ftxui")
+    (version "3.0.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/ArthurSonzogni/FTXUI")
+                    (commit (string-append "v" version))))
+              (sha256
+               (base32
+                "10a4yw2h29kixxyhll6cvrwyscsvz9asxry857a9l8nqvbhs946s"))
+              (file-name (git-file-name name version))))
+    (build-system cmake-build-system)
+    (native-inputs (list googletest))
+    (arguments
+     (list #:configure-flags
+           #~(list "-DFTXUI_BUILD_TESTS:BOOL=ON"
+                   "-DFTXUI_BUILD_TESTS_FUZZER:BOOL=OFF")
+           #:phases
+           #~(modify-phases %standard-phases
+               (add-after 'unpack 'patch-cmake-tests
+                 (lambda _
+                   (substitute* "cmake/ftxui_test.cmake"
+                     (("NOT googletest_POPULATED")
+                      "FALSE"))
+                   ;; Disable benchmarks for a while as they require bundled Google
+                   ;; benchmark and when the 'googlebenchmark' is unbundled, there's
+                   ;; a CMake configuration error.
+                   (substitute* "cmake/ftxui_benchmark.cmake"
+                     (("NOT WIN32")
+                      "FALSE")))) )))
+    (home-page "https://github.com/ArthurSonzogni/FTXUI")
+    (synopsis "C++ Functional Terminal User Interface")
+    (description
+     "Functional Terminal (X) User interface (FTXUI) is a simple C++ library for
+terminal based user interfaces.
+
+Main features:
+@itemize
+@item Functional style.
+@item Keyboard & mouse navigation.
+@item Support for UTF8 and fullwidth chars.
+@item Support for animations.
+@item Support for drawing.
+@item No dependencies.
+@end itemize")
+    (license license:expat)))
-- 
2.34.1