diff mbox series

[bug#65322] gnu: linux-libre: Fix aarch64 build by providing hexdump command

Message ID 87y1icgfa6.fsf@gmx.com
State New
Headers show
Series [bug#65322] gnu: linux-libre: Fix aarch64 build by providing hexdump command | expand

Commit Message

Pierre Langlois Aug. 15, 2023, 9:23 p.m. UTC
Hi Guix!

I noticed linux 6.4 didn't build on aarch64
https://ci.guix.gnu.org/build/1787394/details, building it locally and
checking the log, it seems we're simply missing the `hexdump' column:

--8<---------------cut here---------------start------------->8---
  CC [M]  drivers/pci/controller/pcie-rockchip-host.mod.o
  OBJCOPY arch/arm64/boot/Image
  CC [M]  drivers/pci/controller/pcie-brcmstb.mod.o
  AS      arch/arm64/boot/zboot-header.o
make[1]: hexdump: No such file or directory
make[1]: hexdump: No such file or directory
make[1]: hexdump: No such file or directory
make[1]: hexdump: No such file or directory
  PAD     arch/arm64/boot/vmlinux.bin
  CC [M]  drivers/pci/controller/pcie-apple.mod.o
truncate: Invalid number: 'arch/arm64/boot/vmlinux.bin'
make[1]: *** [drivers/firmware/efi/libstub/Makefile.zboot:13: arch/arm64/boot/vmlinux.bin] Error 1
make[1]: *** Deleting file 'arch/arm64/boot/vmlinux.bin'
make: *** [arch/arm64/Makefile:163: vmlinuz.efi] Error 2
make: *** Waiting for unfinished jobs....
  CC [M]  drivers/pci/pci-stub.mod.o
  CC [M]  drivers/video/backlight/ams369fg06.mod.o
  CC [M]  drivers/video/backlight/lcd.mod.o
  CC [M]  drivers/video/backlight/hx8357.mod.o
--8<---------------cut here---------------end--------------->8---

The "PAD" line seems to come from this Makefile, imported in a few
targets: https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/tree/drivers/firmware/efi/libstub/Makefile.zboot#n7

So the fix is easy! Somebody probably already found the issue, but I
figure I'd post the fix in case it saves time :-)

Thanks!
Pierre

Comments

Mathieu Othacehe Oct. 5, 2023, 3:18 p.m. UTC | #1
Hello Pierre,

> I noticed linux 6.4 didn't build on aarch64
> https://ci.guix.gnu.org/build/1787394/details, building it locally and
> checking the log, it seems we're simply missing the `hexdump' column:

I made a similar patch couple weeks ago without noticing yours, sorry
about that! Closing.

Mathieu
diff mbox series

Patch

From d20fa084807706fd3fccaa2104162843420c282c Mon Sep 17 00:00:00 2001
Message-ID: <d20fa084807706fd3fccaa2104162843420c282c.1692134779.git.pierre.langlois@gmx.com>
From: Pierre Langlois <pierre.langlois@gmx.com>
Date: Tue, 15 Aug 2023 22:10:02 +0100
Subject: [PATCH] gnu: linux-libre: Add util-linux native input.

Provide `hexdump' needed to build compressed EFI payload, on aarch64.

* gnu/packages/linux.scm (make-linux-libre*)[native-inputs]: Add util-linux.
---
 gnu/packages/linux.scm | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 686eb40587..48dda8cda9 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1071,7 +1071,9 @@  (define* (make-linux-libre* version gnu-revision source supported-systems
            ;; These are needed to compile the GCC plugins.
            gmp
            mpfr
-           mpc))
+           mpc
+           ;; Provide hexdump command, needed on aarch64.
+           util-linux))
     (home-page "https://www.gnu.org/software/linux-libre/")
     (synopsis "100% free redistribution of a cleaned Linux kernel")
     (description "GNU Linux-Libre is a free (as in freedom) variant of the

base-commit: 6eb0070f088cfdc4edb98fcfbea4b7aa68a2e30a
--
2.41.0