diff mbox series

[bug#68095] gnu: guile-ssh: Update to 0.16.4.

Message ID 87y1ddzc00.fsf@gmail.com
State New
Headers show
Series [bug#68095] gnu: guile-ssh: Update to 0.16.4. | expand

Commit Message

Artyom V. Poptsov Dec. 29, 2023, 7:47 a.m. UTC
Hello,

this patch updates Guile-SSH to 0.16.4:
- avp

Comments

Ludovic Courtès Jan. 14, 2024, 9:39 p.m. UTC | #1
Hi,

"Artyom V. Poptsov" <poptsov.artyom@gmail.com> skribis:

> From 9ff09d133b2978f727e77e05092e957e0ca46981 Mon Sep 17 00:00:00 2001
> Message-ID: <9ff09d133b2978f727e77e05092e957e0ca46981.1703835285.git.poptsov.artyom@gmail.com>
> From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
> Date: Sat, 23 Dec 2023 10:16:55 +0300
> Subject: [PATCH] gnu: guile-ssh: Update to 0.16.4.
>
> * gnu/packages/ssh.scm (guile-ssh): Update to 0.16.4.
>   [arguments]: Improve the style.
>
> Change-Id: Ib7d741e7f4fc7a1fc167cfa4f7953f84d9f4d390

Applied, but without some of the formatting changes, which I guess
reveal defects in ‘guix style’…

Thanks,
Ludo’.
diff mbox series

Patch

From 9ff09d133b2978f727e77e05092e957e0ca46981 Mon Sep 17 00:00:00 2001
Message-ID: <9ff09d133b2978f727e77e05092e957e0ca46981.1703835285.git.poptsov.artyom@gmail.com>
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Sat, 23 Dec 2023 10:16:55 +0300
Subject: [PATCH] gnu: guile-ssh: Update to 0.16.4.

* gnu/packages/ssh.scm (guile-ssh): Update to 0.16.4.
  [arguments]: Improve the style.

Change-Id: Ib7d741e7f4fc7a1fc167cfa4f7953f84d9f4d390
---
 gnu/packages/ssh.scm | 61 +++++++++++++++++++++++---------------------
 1 file changed, 32 insertions(+), 29 deletions(-)

diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 0b364bbe90..4e9ee675f1 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -18,6 +18,7 @@ 
 ;;; Copyright © 2020, 2021, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2021 Brice Waegeneire <brice@waegenei.re>
 ;;; Copyright © 2023 Simon Streit <simon@netpanic.org>
+;;; Copyright © 2023 Artyom V. Poptsov <poptsov.artyom@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -324,22 +325,22 @@  (define-public openssh-sans-x
 (define-public guile-ssh
   (package
     (name "guile-ssh")
-    (version "0.16.3")
+    (version "0.16.4")
     (home-page "https://github.com/artyom-poptsov/guile-ssh")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                    (url home-page)
-                    (commit (string-append "v" version))))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32
-                "0b03aizjdj3g15xfkspgvy8k5jl8bgv4q7gwjwr3l2ibqkrm8vrz"))))
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url home-page)
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "127yhjaywais3h2g3cxhqmhdmqgxf9j1jwb6wzx92j0z7asrjqwr"))))
     (build-system gnu-build-system)
     (outputs '("out" "debug"))
     (arguments
-     `(;; It makes no sense to build libguile-ssh.a.
-       #:configure-flags '("--disable-static")
+     `( ;It makes no sense to build libguile-ssh.a.
+        #:configure-flags '("--disable-static")
 
        #:phases (modify-phases %standard-phases
                   (add-before 'bootstrap 'support-cross-compilation
@@ -356,36 +357,38 @@  (define-public guile-ssh
                       ;; the .go files.
                       (let* ((out (assoc-ref outputs "out"))
                              (lib (string-append out "/lib")))
-                        (invoke "make" "install"
-                                "-C" "libguile-ssh"
-                                "-j" (number->string
-                                      (parallel-job-count)))
+                        (invoke "make"
+                                "install"
+                                "-C"
+                                "libguile-ssh"
+                                "-j"
+                                (number->string (parallel-job-count)))
                         (substitute* (find-files "." "\\.scm$")
                           (("\"libguile-ssh\"")
-                           (string-append "\"" lib "/libguile-ssh\"")))
-                        #t)))
+                           (string-append "\"" lib "/libguile-ssh\""))))))
                   ,@(if (%current-target-system)
                         '()
-                        '((add-before 'check 'fix-guile-path
-                             (lambda* (#:key inputs #:allow-other-keys)
-                               (let ((guile (assoc-ref inputs "guile")))
-                                 (substitute* "tests/common.scm"
-                                   (("/usr/bin/guile")
-                                    (string-append guile "/bin/guile")))
-                                 #t)))))
+                        '((add-before 'check
+                                      'fix-guile-path
+                                      (lambda* (#:key inputs
+                                                #:allow-other-keys)
+                                        (let ((guile (assoc-ref inputs "guile")))
+                                          (substitute* "tests/common.scm"
+                                            (("/usr/bin/guile")
+                                             (string-append guile
+                                                            "/bin/guile"))))))))
                   (add-after 'install 'remove-bin-directory
                     (lambda* (#:key outputs #:allow-other-keys)
                       (let* ((out (assoc-ref outputs "out"))
                              (bin (string-append out "/bin"))
-                             (examples (string-append
-                                        out "/share/guile-ssh/examples")))
+                             (examples (string-append out
+                                        "/share/guile-ssh/examples")))
                         (mkdir-p examples)
                         (rename-file (string-append bin "/ssshd.scm")
                                      (string-append examples "/ssshd.scm"))
                         (rename-file (string-append bin "/sssh.scm")
                                      (string-append examples "/sssh.scm"))
-                        (delete-file-recursively bin)
-                        #t))))))
+                        (delete-file-recursively bin)))))))
     (native-inputs (list autoconf
                          automake
                          libtool

base-commit: 7722da6fa5422c4fec69d6c8b9536c7d6fc3d326
-- 
2.41.0