diff mbox series

[bug#67143,v2] gnu: Add python-pyreadstat.

Message ID 87y1d1w0ja.fsf@troyfigiel.com
State New
Headers show
Series [bug#67143,v2] gnu: Add python-pyreadstat. | expand

Commit Message

Troy Figiel Jan. 7, 2024, 4:40 p.m. UTC
* gnu/packages/statistics.scm (python-pyreadstat): New variable.
---
 gnu/local.mk                                  |  2 +
 .../python-pyreadstat-link-libiconv.patch     | 15 +++++++
 gnu/packages/statistics.scm                   | 45 +++++++++++++++++++
 3 files changed, 62 insertions(+)
 create mode 100644 gnu/packages/patches/python-pyreadstat-link-libiconv.patch


base-commit: 5f8a993aa85554ca09bd27139230d7664107e1b6

Comments

Mathieu Othacehe Jan. 9, 2024, 9:14 a.m. UTC | #1
Hello,

> * gnu/packages/statistics.scm (python-pyreadstat): New variable.
> ---
>  gnu/local.mk                                  |  2 +
>  .../python-pyreadstat-link-libiconv.patch     | 15 +++++++

You need to comment those in the commit message as well.

I fixed that and applied,

Thanks,

Mathieu
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index 3548b5eb3d..09c4dbaa46 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -62,6 +62,7 @@ 
 # Copyright © 2023 B. Wilson <elaexuotee@wilsonb.com>
 # Copyright © 2023 gemmaro <gemmaro.dev@gmail.com>
 # Copyright © 2023 Herman Rimm <herman@rimm.ee>
+# Copyright © 2023 Troy Figiel <troy@troyfigiel.com>
 #
 # This file is part of GNU Guix.
 #
@@ -1775,6 +1776,7 @@  dist_patch_DATA =						\
   %D%/packages/patches/python-louvain-fix-test.patch		\
   %D%/packages/patches/python-random2-getrandbits-test.patch		\
   %D%/packages/patches/python-poppler-qt5-fix-build.patch	\
+  %D%/packages/patches/python-pyreadstat-link-libiconv.patch	\
   %D%/packages/patches/python-pypdf-annotate-tests-appropriately.patch	\
   %D%/packages/patches/python-pytorch2-system-libraries.patch	\
   %D%/packages/patches/python-sip-include-dirs.patch	\
diff --git a/gnu/packages/patches/python-pyreadstat-link-libiconv.patch b/gnu/packages/patches/python-pyreadstat-link-libiconv.patch
new file mode 100644
index 0000000000..7efd71faeb
--- /dev/null
+++ b/gnu/packages/patches/python-pyreadstat-link-libiconv.patch
@@ -0,0 +1,15 @@ 
+To ensure libiconv can be found by Guix, we need to link the library.
+
+--- a/setup.py
++++ b/setup.py
+@@ -81,8 +81,7 @@ else:
+     libraries.extend(["m", "z"])
+     _platform = sys.platform
+     # Mac: iconv needs to be linked statically
+-    if _platform.lower().startswith("darwin"):
+-        libraries.append("iconv")
++    libraries.append("iconv")
+ 
+ # Extensions
+ sources.sort()
+
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 712b1a9c37..906ec456b6 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -18,6 +18,7 @@ 
 ;;; Copyright © 2021 Frank Pursel <frank.pursel@gmail.com>
 ;;; Copyright © 2022 Simon Tournier <zimon.toutoune@gmail.com>
 ;;; Copyright © 2023 gemmaro <gemmaro.dev@gmail.com>
+;;; Copyright © 2023 Troy Figiel <troy@troyfigiel.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -6919,6 +6920,50 @@  (define-public readstat
 popular stats packages like SAS, Stata and SPSS.")
     (license license:expat)))
 
+(define-public python-pyreadstat
+  (package
+    (name "python-pyreadstat")
+    (version "1.2.4")
+    ;; No tests in the PyPI tarball.
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/Roche/pyreadstat")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0zysrzixvqw2lwwykxqg5yj8a0zyv5s2bmk22x30f4rj2hgvq1pv"))
+       (patches (search-patches "python-pyreadstat-link-libiconv.patch"))))
+    (arguments
+     '(#:phases (modify-phases %standard-phases
+                  (add-before 'check 'change-home-dir
+                    (lambda _
+                      ;; test_sav_expand and test_sav_write_basic_expanduser need a
+                      ;; home directory with write permissions.
+                      (setenv "HOME" "/tmp")))
+                  (replace 'check
+                    (lambda* (#:key tests? #:allow-other-keys)
+                      (when tests?
+                        ;; The source also contains tests/test_version.py
+                        ;; which checks the version in __init__.py against the
+                        ;; one in setup.py. Since this requires texlive
+                        ;; dependencies to run and is also not mentioned in
+                        ;; how_to_test.md, this test is skipped.
+                        (invoke "python" "tests/test_basic.py")))))))
+    (build-system python-build-system)
+    (propagated-inputs (list python-pandas))
+    (inputs (list libiconv zlib))
+    (native-inputs (list python-cython-3))
+    (home-page "https://github.com/Roche/pyreadstat")
+    (synopsis
+     "Read and write SAS, SPSS and Stata files into/from Pandas DataFrames")
+    (description
+     "This Python package can be used to read and write SAS, SPSS and Stata
+files into/from Pandas DataFrames.  It is a wrapper around the C library
+@code{readstat}.")
+    (license license:asl2.0)))
+
 (define-public r-quantpsyc
   (package
     (name "r-quantpsyc")