diff mbox series

[bug#69015,2/3] gnu: go-etcd-io-bbolt: Move to (gnu packages golang-xyz).

Message ID 87y1bs9dzy.fsf@troyfigiel.com
State New
Headers show
Series None | expand

Commit Message

Troy Figiel Feb. 10, 2024, 9:29 p.m. UTC
* gnu/packages/configuration-management.scm: Add (gnu packages golang-xyz) to used modules.
* gnu/packages/databases.scm (go-etcd-io-bbolt): Move from here ...
* gnu/packages/golang-xyz.scm: ... to here.
---
 gnu/packages/configuration-management.scm |  1 +
 gnu/packages/golang-xyz.scm               | 26 +++++++++++++++++++++++
 gnu/packages/golang.scm                   | 23 --------------------
 3 files changed, 27 insertions(+), 23 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/configuration-management.scm b/gnu/packages/configuration-management.scm
index 296f48dcd5..aedf4f38e4 100644
--- a/gnu/packages/configuration-management.scm
+++ b/gnu/packages/configuration-management.scm
@@ -22,6 +22,7 @@  (define-module (gnu packages configuration-management)
   #:use-module (guix git-download)
   #:use-module (gnu packages golang)
   #:use-module (gnu packages golang-web)
+  #:use-module (gnu packages golang-xyz)
   #:use-module (gnu packages version-control)
   #:use-module (gnu packages textutils)
   #:use-module ((guix licenses) #:prefix license:)
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index d52cbedd9c..fe46a87093 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1,4 +1,7 @@ 
 ;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
+;;; Copyright © 2021 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
 ;;; Copyright © 2022 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2023 Benjamin <benjamin@uvy.fr>
 ;;; Copyright © 2023 Thomas Ieong <th.ieong@free.fr>
@@ -39,6 +42,29 @@  (define-module (gnu packages golang-xyz)
 ;;;
 ;;; Code:
 
+(define-public go-etcd-io-bbolt
+  (package
+    (name "go-etcd-io-bbolt")
+    (version "1.3.6")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/etcd-io/bbolt")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0pj5245d417za41j6p09fmkbv05797vykr1bi9a6rnwddh1dbs8d"))))
+    (build-system go-build-system)
+    (arguments
+     `(#:import-path "go.etcd.io/bbolt"))
+    (propagated-inputs
+     (list go-golang-org-x-sys))
+    (home-page "https://pkg.go.dev/go.etcd.io/bbolt/")
+    (synopsis "Low-level key/value store in Go")
+    (description "This package implements a low-level key/value store in Go.")
+    (license license:expat)))
+
 (define-public go-github-com-djherbis-atime
   (package
     (name "go-github-com-djherbis-atime")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 163691a1e6..5d3b39d1a9 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9328,29 +9328,6 @@  (define-public go-github-com-zclconf-go-cty
 configuration languages, but other uses may be possible too.")
     (license license:expat)))
 
-(define-public go-etcd-io-bbolt
-  (package
-    (name "go-etcd-io-bbolt")
-    (version "1.3.6")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                    (url "https://github.com/etcd-io/bbolt")
-                    (commit (string-append "v" version))))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32
-                "0pj5245d417za41j6p09fmkbv05797vykr1bi9a6rnwddh1dbs8d"))))
-    (build-system go-build-system)
-    (arguments
-     `(#:import-path "go.etcd.io/bbolt"))
-    (propagated-inputs
-     (list go-golang-org-x-sys))
-    (home-page "https://pkg.go.dev/go.etcd.io/bbolt/")
-    (synopsis "Low-level key/value store in Go")
-    (description "This package implements a low-level key/value store in Go.")
-    (license license:expat)))
-
 (define-public go-github-com-bwesterb-go-ristretto
   (package
     (name "go-github-com-bwesterb-go-ristretto")