diff mbox series

[bug#69216] gnu: Add go-github-com-coocood-freecache.

Message ID 87y1bi9btr.fsf@troyfigiel.com
State New
Headers show
Series [bug#69216] gnu: Add go-github-com-coocood-freecache. | expand

Commit Message

Troy Figiel Feb. 18, 2024, 12:45 p.m. UTC
* gnu/packages/golang-xyz.scm (go-github-com-coocood-freecache): New variable.
---
 gnu/packages/golang-xyz.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)


base-commit: 2f1ed825afa535693f7fe32b9e3e9128cc8f99c9

Comments

Sharlatan Hellseher Feb. 19, 2024, 11:50 p.m. UTC | #1
Hi,

Pushed as f5de1f96ed46c427b67d78304977884ff7165538 to master.

--
Oleg
diff mbox series

Patch

diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index b0a5955405..ab9127f588 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -264,6 +264,33 @@  (define-public go-github-com-burntsushi-toml
 similar to Go's standard library @code{json} and @code{xml} package.")
     (license license:expat)))
 
+(define-public go-github-com-coocood-freecache
+  (package
+    (name "go-github-com-coocood-freecache")
+    (version "1.2.4")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/coocood/freecache")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0iw0s07qy8g1lncwl524c524wh56djl0vn6i3bm91cnwzav7ihjl"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/coocood/freecache"))
+    (propagated-inputs (list go-github-com-cespare-xxhash))
+    (home-page "https://github.com/coocood/freecache")
+    (synopsis "Caching library for Go")
+    (description
+     "This library provides caching capabilities for Go with no garbage
+collection overhead and high concurrent performance.  An unlimited number of
+objects can be cached in memory without increased latency or degraded
+throughput.")
+    (license license:expat)))
+
 (define-public go-github-com-coreos-go-systemd-activation
   (package
     (name "go-github-com-coreos-go-systemd-activation")