diff mbox series

[bug#69884] gnu: Add python-recurring-ical-events.

Message ID 87y1afxif6.fsf@lambda-y.net
State New
Headers show
Series [bug#69884] gnu: Add python-recurring-ical-events. | expand

Commit Message

Benjamin Slade March 18, 2024, 10:51 p.m. UTC

Comments

Skyler Ferris March 20, 2024, 7:36 p.m. UTC | #1
Hi Benjamin,

It looks like this patch is dependent on the patch you submitted in 
69885. Please re-submit this in a series with all dependent patches in 
the correct order. Additionally, the same notes about updating 
dependencies, rather than skipping tests, applies here. I'm going to 
close this issue and use 69885 as the canonical issue for this set of 
patches, feel free to reach out there if you have any problems.

Regards,
Skyler
diff mbox series

Patch

From f7ea1140bb2937dd2d41f858ca8a39cd4b423e76 Mon Sep 17 00:00:00 2001
From: Benjamin Slade <slade@lambda-y.net>
Date: Mon, 18 Mar 2024 17:50:14 -0500
Subject: [PATCH] gnu: Add python-recurring-ical-events.

* gnu/packages/python-xyz.scm (python-recurring-ical-events): New variable
---
 gnu/packages/python-xyz.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 17ce6ef..1f3272e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -17623,6 +17623,32 @@  (define-public python-execnet
       (home-page "https://codespeak.net/execnet/")
       (license license:expat))))
 
+(define-public python-recurring-ical-events
+  (package
+    (name "python-recurring-ical-events")
+    (version "2.1.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "recurring_ical_events" version))
+       (sha256
+        (base32 "00k4l800j2d3zfqhxjlzjk0b6493wqhmg4r58xsp12sx2ia2sxla"))))
+    (build-system python-build-system)
+    (arguments
+     ;; Broken tests or cyclic dependecies with other packages.
+     '(#:phases (modify-phases %standard-phases
+                  (delete 'sanity-check))
+       #:tests? #f))
+    (propagated-inputs (list python-x-wr-timezone python-icalendar python-pytz))
+    (home-page "https://github.com/niccokunzmann/python-recurring-ical-events")
+    (synopsis
+     "Python library for recurrence of ical events based on icalendar")
+    (description
+     "ICal has some complexity to it: Events, TODOs and Journal entries can
+ be repeated, removed from the feed and edited later on.
+This tool takes care of these circumstances.")
+    (license license:lgpl3+)))
+
 (define-public python-x-wr-timezone
   (package
     (name "python-x-wr-timezone")
-- 
2.41.0