From 49c7cfc32f7263c78bf2b555dfad8cfcaf6db8eb Mon Sep 17 00:00:00 2001
From: Vagrant Cascadian <vagrant@debian.org>
Date: Thu, 7 Feb 2019 00:07:49 +0000
Subject: [PATCH 2/2] gnu: trezor-agent: Update 0.10.0.
Fixes <https://bugs.gnu.org/34377>.
* gnu/packages/finance.scm (trezor-agent): Update to 0.10.0.
[phases]: Add fixup-agent-py phase to install trezor_agent.py without shell
wrapper.
[native-inputs]: Add python-hidapi.
[home-page]: Use https url.
---
gnu/packages/finance.scm | 19 ++++++++++++++++---
1 file changed, 16 insertions(+), 3 deletions(-)
@@ -803,19 +803,32 @@ Then set the environment variable GNUPGHOME to
(define-public trezor-agent
(package
(name "trezor-agent")
- (version "0.9.0")
+ (version "0.10.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "trezor_agent" version))
(sha256
(base32
- "1i5cdamlf3c0ym600pjklij74p8ifj9cv7xrpnrfl1b8nkadswbz"))))
+ "144657c7bn0a667dq5fv5r6j7iilxf3h9agj29v1m2qpq40g0az8"))))
+ (arguments
+ ;; Tests fail with "AttributeError: module 'attr' has no attribute 's'".
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'wrap 'fixup-agent-py
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out")))
+ ;; overwrite the wrapper with the real thing.
+ (install-file "./trezor_agent.py"
+ (string-append out "/bin/"))
+ #t))))))
(build-system python-build-system)
(inputs
`(("python-trezor" ,python-trezor)
("python-trezor-agent" ,python-trezor-agent)))
- (home-page "http://github.com/romanz/trezor-agent")
+ (native-inputs
+ `(("python-hidapi" ,python-hidapi)))
+ (home-page "https://github.com/romanz/trezor-agent")
(synopsis "Using Trezor as hardware SSH/GPG agent")
(description "This package allows using Trezor as a hardware SSH/GPG
agent.")
--
2.20.1