diff mbox series

[bug#37358] Add emacs-doom-themes

Message ID 87woeevkwu.fsf@yahoo.de
State Accepted
Headers show
Series [bug#37358] Add emacs-doom-themes | expand

Commit Message

ashish.is--- via Guix-patches" via Sept. 11, 2019, 4:48 p.m. UTC
Hi,

Ludovic Courtès writes:
> Why is this needed?

I am pretty sure that this is not what I want (did I miss a build-system
option?):
The themes of the package are in a subdirectory that is not byte
compiled or installed to the store when the package is build.
The easiest workaround I could come up with is copying all .el files to
the root of the package.
The package is pretty useless without the theme .el files.

> I could suggest:
>
>   (for-each (lambda (file)
>               (rename-file file (string-append (dirname file) "/..")))
>             (find-files themes))
>
> … which would really move files, but it also more verbose.

A version moving the files is attached. I would prefer the copying
version however: The files will not get installed, we are talking about
a few kilobytes in /tmp/, and it is easier to read.
Choose the version you like :)

Tim.

Comments

Brett Gilio Sept. 11, 2019, 6:13 p.m. UTC | #1
Hi all,

I have a copy of emacs-doom-themes in my channel here. I never pushed it 
because I didnt feel it was good enough for upstream.

It works though, feel free to tweak it and push it.

https://git.sr.ht/~brettgilio/cfg/tree/master/guix-channel/non-gnu/packages/emacs-xyz.scm#L10

On 11.09.2019 18:48, Tim Gesthuizen via Guix-patches via wrote:
> Hi,
> 
> Ludovic Courtès writes:
>> Why is this needed?
> 
> I am pretty sure that this is not what I want (did I miss a 
> build-system
> option?):
> The themes of the package are in a subdirectory that is not byte
> compiled or installed to the store when the package is build.
> The easiest workaround I could come up with is copying all .el files to
> the root of the package.
> The package is pretty useless without the theme .el files.
> 
>> I could suggest:
>> 
>>   (for-each (lambda (file)
>>               (rename-file file (string-append (dirname file) "/..")))
>>             (find-files themes))
>> 
>> … which would really move files, but it also more verbose.
> 
> A version moving the files is attached. I would prefer the copying
> version however: The files will not get installed, we are talking about
> a few kilobytes in /tmp/, and it is easier to read.
> Choose the version you like :)
> 
> Tim.
Ludovic Courtès Sept. 12, 2019, 9:22 p.m. UTC | #2
Hi Brett,

brettg@posteo.net skribis:

> I have a copy of emacs-doom-themes in my channel here. I never pushed
> it because I didnt feel it was good enough for upstream.

Ah ha, too much self-censorship!

> It works though, feel free to tweak it and push it.
>
> https://git.sr.ht/~brettgilio/cfg/tree/master/guix-channel/non-gnu/packages/emacs-xyz.scm#L10

I’ve added some of the bits of your version that were missing, marked
you as co-author, and committed.

Thanks to both of you!

Ludo’.
diff mbox series

Patch

From b775f49533df6af3a3646547abeb2ca627f401c8 Mon Sep 17 00:00:00 2001
From: Tim Gesthuizen <tim.gesthuizen@yahoo.de>
Date: Mon, 9 Sep 2019 18:48:31 +0200
Subject: [PATCH] gnu: Add emacs-doom-themes

* gnu/packages/emacs-xyz.scm (emacs-doom-themes): New variable.
---
 gnu/packages/emacs-xyz.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index f3de24d825..d39a176e4f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -18200,3 +18200,31 @@  You can customize: @code{tao-theme-scale-fn}, that returns 16 2-digit numbers;
 @code{tao-theme-scale-filter-fn}, for edge filter; and
 @code{tao-theme-use-height}.")
       (license license:gpl3+))))
+
+(define-public emacs-doom-themes
+  (package
+    (name "emacs-doom-themes")
+    (version "2.1.6")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/hlissner/emacs-doom-themes.git")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256 (base32 "042pzcdhxi2z07jcscgjbaki9nrrm0cbgbbrnymd1r4q8ckkn8l9"))))
+    (build-system emacs-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack
+             'move-themes
+           (lambda _
+             (for-each
+              (lambda (file)
+                (rename-file file (string-append (dirname file) "/../" (basename file))))
+              (find-files "themes")))))))
+    (synopsis "Wide collection of color themes for emacs")
+    (description "emacs-doom-themes contains numerous popular color themes for
+emacs that integrate with major modes like org-mode.")
+    (home-page "https://github.com/hlissner/emacs-doom-themes")
+    (license license:expat)))
-- 
2.23.0