diff mbox series

[bug#37567] gnu: pulseaudio: Add optional X11 inputs.

Message ID 87wodowxvl.fsf@GlaDOS.home
State Accepted
Headers show
Series [bug#37567] gnu: pulseaudio: Add optional X11 inputs. | expand

Commit Message

Diego Nicola Barbato Oct. 1, 2019, 10:42 a.m. UTC
Hello Guix,

Pulseaudio is currently built without the optional X11 modules (e.g
module-x11-bell, which makes it possible to customize the x11-bell
sound).  This patch adds those X11 libraries to Pulseaudios's inputs,
which are necessary for the modules to be built.

Regards,

Diego

Comments

Marius Bakke Oct. 13, 2019, 9:09 p.m. UTC | #1
Diego Nicola Barbato <dnbarbato@posteo.de> writes:

> Hello Guix,
>
> Pulseaudio is currently built without the optional X11 modules (e.g
> module-x11-bell, which makes it possible to customize the x11-bell
> sound).  This patch adds those X11 libraries to Pulseaudios's inputs,
> which are necessary for the modules to be built.

This patch increases the size of pulseaudio from 187.2 MiB to 189.4 MiB,
which is OK IMO.

Pushed to 'staging' with a minor cosmetic change in 531b63eba7.

Thank you!
diff mbox series

Patch

From 3bcfda0a26a572b6789a469ea6da4d384db4be47 Mon Sep 17 00:00:00 2001
From: Diego Nicola Barbato <dnbarbato@posteo.de>
Date: Tue, 1 Oct 2019 11:31:42 +0200
Subject: [PATCH] gnu: pulseaudio: Add optional X11 inputs.

* gnu/packages/pulseaudio.scm (pulseaudio)[inputs]: Add libxcb, libice, libsm,
  and libxtst.
---
 gnu/packages/pulseaudio.scm | 7 ++++++-
 1 file changed, 6 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/pulseaudio.scm b/gnu/packages/pulseaudio.scm
index fa48d8a7a6..f0f8574078 100644
--- a/gnu/packages/pulseaudio.scm
+++ b/gnu/packages/pulseaudio.scm
@@ -50,7 +50,8 @@ 
   #:use-module (gnu packages python-xyz)
   #:use-module (gnu packages python-web)
   #:use-module (gnu packages pkg-config)
-  #:use-module (gnu packages xiph))
+  #:use-module (gnu packages xiph)
+  #:use-module (gnu packages xorg))
 
 (define-public libsndfile
   (package
@@ -187,6 +188,10 @@  rates.")
        ("libltdl" ,libltdl)
        ("fftwf" ,fftwf)
        ("avahi" ,avahi)
+       ("libxcb" ,libxcb)   ; For enabling X11.
+       ("libice" ,libice)   ; For enabling X11.
+       ("libsm" ,libsm)     ; For enabling X11.
+       ("libxtst" ,libxtst) ; For enabling X11.
        ("eudev" ,eudev)))         ;for the detection of hardware audio devices
     (native-inputs
      `(("check" ,check)
-- 
2.23.0