diff mbox series

bug#38094: [PATCH] gnu: Add homebank.

Message ID 87wocaaqmn.fsf@gnu.org
State Accepted
Headers show
Series bug#38094: [PATCH] gnu: Add homebank. | expand

Commit Message

Ludovic Courtès Nov. 8, 2019, 11:35 p.m. UTC
Hi Sebastian,

Sebastian Schott <sschott@mailbox.org> skribis:

> ---
>  gnu/packages/finance.scm | 26 ++++++++++++++++++++++++++
>  1 file changed, 26 insertions(+)

Applied!

I took the liberty to make apply the cosmetic changes below to follow
our guidelines, in particular
<https://guix.gnu.org/manual/en/html_node/Synopses-and-Descriptions.html>.
I also added a commit log that follows our conventions.

Thank you!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index fd29099aa3..c9a1637412 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -156,13 +156,13 @@  line client and a client based on Qt.")
   (package
     (name "homebank")
     (version "5.2.8")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (string-append "http://homebank.free.fr/public/homebank-" version ".tar.gz"))
-       (sha256
-        (base32
-         "13ampiv68y30kc0p2560g3yz8whqpwnidfcnb9lndv93b9ca767y"))))
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "http://homebank.free.fr/public/homebank-"
+                                  version ".tar.gz"))
+              (sha256
+               (base32
+                "13ampiv68y30kc0p2560g3yz8whqpwnidfcnb9lndv93b9ca767y"))))
     (build-system glib-or-gtk-build-system)
     (native-inputs
      `(("pkg-config" ,pkg-config)
@@ -173,8 +173,11 @@  line client and a client based on Qt.")
     (arguments
      `(#:configure-flags (list "-without-ofx"))) ; libofx is not available yet
     (home-page "http://homebank.free.fr/")
-    (synopsis "Free, easy, personal accounting for everyone")
-    (description "HomeBank is the free software you have always wanted to manage your personal accounts at home.  The main concept is to be light, simple and very easy to use.  It brings you many features that allows you to analyze your finances in a detailed way instantly and dynamically with powerful report tools based on filtering and graphical charts.")
+    (synopsis "Graphical personal accounting application")
+    (description "HomeBank allows you to manage your personal accounts at
+home.  The seeks to be lightweight, simple and easy to use.  It brings
+features that allow you to analyze your finances in a detailed way instantly
+and dynamically with report tools based on filtering and graphical charts.")
     (license license:gpl2+)))
 
 (define-public ledger