diff mbox series

[bug#40257] gnu: Add emacs-elm-mode.

Message ID 87wo75iii1.fsf@asu.edu
State Accepted
Headers show
Series [bug#40257] gnu: Add emacs-elm-mode. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

John Soo March 27, 2020, 9:40 p.m. UTC
Hi Guix!

Elm-mode provides Elm syntax highlighting and some other niceties.

Thanks,

John

Comments

Nicolas Goaziou March 30, 2020, 12:16 p.m. UTC | #1
Hello,

John Soo <jsoo1@asu.edu> writes:

> Elm-mode provides Elm syntax highlighting and some other niceties.

Thank you! I expounded the synopsis and the description a bit, and
pushed as 1d3c1f4b4965e93be6301dacf9abe16b4e4ef944.

Regards,
diff mbox series

Patch

From 59807f2d9ff05d5732a047ba1f951494dd6661dd Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Thu, 19 Mar 2020 09:18:18 -0700
Subject: [PATCH] gnu: Add emacs-elm-mode.

* gnu/packages/emacs-xyz.scm (emacs-elm-mode): New variable.
---
 gnu/packages/emacs-xyz.scm | 40 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 40 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 5653796731..ad986f1f20 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -65,6 +65,7 @@ 
 ;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
 ;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
 ;;; Copyright © 2020 6033fe7de85d <6033fe7de85d@airmail.cc>
+;;; Copyright © 2020 John Soo <jsoo1@asu.edu>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -21774,3 +21775,42 @@  enables modal editing and composition of commands, too.  It combines ideas of
 other Editors like Vim or Kakoune and tries to align them with regular Emacs
 conventions.")
     (license license:gpl3+)))
+
+(define-public emacs-elm-mode
+  (package
+    (name "emacs-elm-mode")
+    (version "0.21.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri
+        (git-reference
+         (url "https://github.com/jcollard/elm-mode")
+         (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "0iwk4fmw8hq3ry4ky1zc7lgl4cpbnrjyk74c2xzddfspi3ks41fd"))))
+    (inputs
+     `(("emacs-dash" ,emacs-dash)
+       ("emacs-f" ,emacs-f)
+       ("emacs-reformatter" ,emacs-reformatter)
+       ("emacs-s" ,emacs-s)))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/jcollard/elm-mode")
+    (synopsis "Elm mode for Emacs")
+    (description
+     "Features
+
+@itemize
+@item Syntax highlighting
+@item Intelligent indentation
+@item Integration with elm-make
+@item Integration with elm-repl
+@item Integration with elm-reactor
+@item Integration with elm-package
+@item Integration with elm-oracle
+@item Integration with elm-format
+@item Integration with elm-test
+@end itemize")
+    (license license:gpl3+)))
-- 
2.26.0