diff mbox series

bug#42011: [PATCH v2] gnu: Add gmic.

Message ID 87wo3w6zse.fsf@gnu.org
State Accepted
Headers show
Series bug#42011: [PATCH v2] gnu: Add gmic. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Marius Bakke June 24, 2020, 7:15 p.m. UTC
Vinicius Monego <monego@posteo.net> writes:

> * gnu/packages/image-processing.scm (gmic): New variable.

Applied with the following cosmetic/idiomatic improvements:
Thanks!
diff mbox series

Patch

diff --git a/gnu/packages/image-processing.scm b/gnu/packages/image-processing.scm
index 64b6395501..a11b1b89d3 100644
--- a/gnu/packages/image-processing.scm
+++ b/gnu/packages/image-processing.scm
@@ -494,15 +494,14 @@  due to its architecture which automatically parallelises the image workflows.")
     (version "2.9.1")
     (source
      (origin
-      (method url-fetch)
-      (uri (string-append
-            "https://gmic.eu/files/source/gmic_"
-            version ".tar.gz"))
-      (sha256
-       (base32 "13axx7nwchn6ysgpvlw3fib474q4nrwv3qn20g3q03ldid0xvjah"))))
+       (method url-fetch)
+       (uri (string-append "https://gmic.eu/files/source/gmic_"
+                           version ".tar.gz"))
+       (sha256
+        (base32 "13axx7nwchn6ysgpvlw3fib474q4nrwv3qn20g3q03ldid0xvjah"))))
     (build-system cmake-build-system)
     (arguments
-     `(#:tests? #f)) ;; There are no tests.
+     `(#:tests? #f))                    ;there are no tests
     (native-inputs
      `(("pkg-config" ,pkg-config)))
     (inputs
@@ -513,7 +512,7 @@  due to its architecture which automatically parallelises the image workflows.")
        ("libpng" ,libpng)
        ("libtiff" ,libtiff)
        ("libx11" ,libx11)
-       ;;("opencv" ,opencv) ; OpenCV is currently broken in the CI
+       ;;("opencv" ,opencv) ;OpenCV is currently broken in the CI
        ("openexr" ,openexr)
        ("zlib" ,zlib)))
     (home-page "https://gmic.eu/")
@@ -523,8 +522,8 @@  processing.  It provides several user interfaces to convert / manipulate
 / filter / visualize generic image datasets, ranging from 1D scalar
 signals to 3D+t sequences of multi-spectral volumetric images, hence
 including 2D color images.")
-    (license (list license:cecill ;; Dual-licensed, either license applies.
-                   license:cecill-c))))
+    ;; Dual-licensed, either license applies.
+    (license (list license:cecill license:cecill-c))))
 
 (define-public nip2
   (package