diff mbox series

bug#47656: [PATCH] Add boost mpi

Message ID 87wntb4giz.fsf@gnu.org
State Accepted
Headers show
Series bug#47656: [PATCH] Add boost mpi | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Ludovic Courtès April 9, 2021, 3:35 p.m. UTC
Hi Franck,

Franck Pérignon <Franck.Perignon@univ-grenoble-alpes.fr> skribis:

> From be7a3cb3bf4060ed4430c36d797127d4268ab446 Mon Sep 17 00:00:00 2001
> From: =?UTF-8?q?Franck=20P=C3=A9rignon?=
>  <Franck.Perignon@univ-grenoble-alpes.fr>
> Date: Thu, 8 Apr 2021 13:42:27 +0000
> Subject: [PATCH] =?UTF-8?q?[PATCH]=C2=A0add=20boost-mpi?=
> MIME-Version: 1.0
> Content-Type: text/plain; charset=UTF-8
> Content-Transfer-Encoding: 8bit
>
> ---
>  gnu/packages/boost.scm | 27 +++++++++++++++++++++++++++
>  1 file changed, 27 insertions(+)

Applied with the cosmetic changes below.

Thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/boost.scm b/gnu/packages/boost.scm
index db0f79f3b0..a59bb01f3d 100644
--- a/gnu/packages/boost.scm
+++ b/gnu/packages/boost.scm
@@ -363,16 +363,15 @@  signals and slots system.")
     (arguments
      (substitute-keyword-arguments (package-arguments boost)
       ((#:phases phases)
-        `(modify-phases ,phases
-         (add-after 'configure 'update-jam
-           (lambda* (#:key inputs outputs #:allow-other-keys)
-             (let ((output-port (open-file "project-config.jam" "a")))
-               (display "using mpi ;" output-port)
-               (newline output-port)
-               (close output-port))))))))
+       `(modify-phases ,phases
+          (add-after 'configure 'update-jam
+            (lambda* (#:key inputs outputs #:allow-other-keys)
+              (let ((output-port (open-file "project-config.jam" "a")))
+                (display "using mpi ;" output-port)
+                (newline output-port)
+                (close output-port))))))))
     (home-page "https://www.boost.org")
-    (synopsis "Message Passing Interface library")
-    (license (license:x11-style "https://www.boost.org/LICENSE_1_0.txt"))))
+    (synopsis "Message Passing Interface (MPI) library for C++")))
 
 (define-public mdds
   (package