diff mbox series

bug#49492: [PATCH] add python-pyhull

Message ID 87wnpmkysa.fsf@gnu.org
State Accepted
Headers show
Series bug#49492: [PATCH] add python-pyhull | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Ludovic Courtès July 19, 2021, 5:18 p.m. UTC
Hi Franck,

Franck Pérignon <Franck.Perignon@univ-grenoble-alpes.fr> skribis:

> From 01ce9e6929fc9681ec0662a7a9673390def38449 Mon Sep 17 00:00:00 2001
> From: =?UTF-8?q?Franck=20P=C3=A9rignon?=
>  <franck.perignon@univ-grenoble-alpes.fr>
> Date: Fri, 9 Jul 2021 16:27:18 +0200
> Subject: [PATCH] [PATCH] Add python-pyhull
>
> ---
>  gnu/packages/python-xyz.scm | 26 ++++++++++++++++++++++++++
>  1 file changed, 26 insertions(+)

Applied!  I took the liberty to apply the following cosmetic changes to
indentation and to the description to better match our conventions:

  https://guix.gnu.org/manual/en/html_node/Submitting-Patches.html

Thank you!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5161e74c05..46419d4b45 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -26016,26 +26016,23 @@  enabling you to write CommonMark inside of Docutils & Sphinx projects.")
     (license license:expat)))
 
 (define-public python-pyhull
-(package
-  (name "python-pyhull")
-  (version "2015.2.1")
-  (source
-    (origin
-      (method url-fetch)
-      (uri (pypi-uri "pyhull" version))
-      (sha256
+  (package
+    (name "python-pyhull")
+    (version "2015.2.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pyhull" version))
+       (sha256
         (base32
-          "091sph52c4yk1jlm5w8xidxpzbia9r7s42bnb23q4m4b56ihmzyj"))))
-  (build-system python-build-system)
-  (propagated-inputs
-    `(("python-numpy" ,python-numpy)))
-  (home-page
-    "https://github.com/materialsvirtuallab/pyhull")
-  (synopsis
-    "Python wrapper to Qhull")
-  (description
-    "A Python wrapper to Qhull (http://www.qhull.org/)
-     for the computation of the convex hull,
-     Delaunay triangulation and Voronoi diagram")
-  (license license:expat)))
-
+         "091sph52c4yk1jlm5w8xidxpzbia9r7s42bnb23q4m4b56ihmzyj"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-numpy" ,python-numpy)))
+    (home-page "https://github.com/materialsvirtuallab/pyhull")
+    (synopsis "Python wrapper to Qhull")
+    (description
+     "This package provides a Python wrapper to @uref{http://www.qhull.org/,
+Qhull} for the computation of the convex hull, Delaunay triangulation, and
+Voronoi diagram.")
+    (license license:expat)))