diff mbox

[bug#58654,0/3] add velox

Message ID 87wn7e92e0.fsf_-_@gnu.org
State New
Headers show

Commit Message

Ludovic Courtès Nov. 28, 2022, 9:48 p.m. UTC
Hi,

zamfofex <zamfofex@twdb.moe> skribis:

> * gnu/packages/wm.scm (swc): New variable.

Finally applied with the changes below to address ‘guix lint’ warnings.

Thanks and apologies for the delay!

Ludo’.
diff mbox

Patch

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index f873101615..96b3c3a666 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -2997,14 +2997,15 @@  (define-public swc
       (source (origin
                 (method git-fetch)
                 (uri (git-reference
-                       (url "https://github.com/michaelforney/swc")
-                       (commit commit)))
+                      (url "https://github.com/michaelforney/swc")
+                      (commit commit)))
                 (sha256
-                  (base32
-                    "19rpbwpi81pm92fkhsmbx7pzagpah5m9ih5h5k3m8dy6r8ihdh35"))))
+                 (base32
+                  "19rpbwpi81pm92fkhsmbx7pzagpah5m9ih5h5k3m8dy6r8ihdh35"))
+                (file-name (git-file-name name version))))
       (build-system gnu-build-system)
       (arguments
-       `(#:tests? #f ; no tests
+       `(#:tests? #f                              ;no tests
          #:make-flags
          (list (string-append "CC=" ,(cc-for-target))
                (string-append "PREFIX=" %output))
@@ -3021,7 +3022,7 @@  (define-public swc
                     xcb-util-wm))
       (native-inputs (list pkg-config))
       (home-page "https://github.com/michaelforney/swc")
-      (synopsis "A library for making a simple Wayland compositor")
+      (synopsis "Library for making a simple Wayland compositor")
       (description "swc is a small Wayland compositor implemented as a library.
 
 It has been designed primarily with tiling window managers in mind.  Additionally,