diff mbox series

[bug#59959] gnu: freecad: Fix the package hash.

Message ID 87wn6yqy9l.fsf@gmail.com
State New
Headers show
Series [bug#59959] gnu: freecad: Fix the package hash. | expand

Commit Message

Artyom V. Poptsov Dec. 11, 2022, 5:56 a.m. UTC
Hello,

it seems that the FreeCAD package hash is incorrect as when I try to
build the package I get the following error:

--8<---------------cut here---------------start------------->8---
building /gnu/store/xfaipns1rr4l4zmkc5p4q0ikd0r6srz6-freecad-0.20.2-checkout.drv...
\r:sha256 hash mismatch for /gnu/store/3lf0plqrf3rwcvd2vlkwaxcc997mivl0-freecad-0.20.2-checkout:
  expected hash: 02976k91ypv41rqdl27jbmyhnhgx7k5bj520lcqs8qzgcdsynd03
  actual hash:   0wsfz2jqfhmqshyr1n4qxcc3c6a96gyll4h34vn2zzvvcnncn9rb
hash mismatch for store item '/gnu/store/3lf0plqrf3rwcvd2vlkwaxcc997mivl0-freecad-0.20.2-checkout'
build of /gnu/store/xfaipns1rr4l4zmkc5p4q0ikd0r6srz6-freecad-0.20.2-checkout.drv failed
View build log at '/var/log/guix/drvs/xf/aipns1rr4l4zmkc5p4q0ikd0r6srz6-freecad-0.20.2-checkout.drv.gz'.
cannot build derivation `/gnu/store/nv4ij1q5106bjv6mpsr2bincifbvynad-freecad-0.20.2.drv': 1 dependencies couldn't be built
guix upgrade: error: build of `/gnu/store/nv4ij1q5106bjv6mpsr2bincifbvynad-freecad-0.20.2.drv' failed
--8<---------------cut here---------------end--------------->8---

Here's a patch that fixes the hash.
Thanks,
- avp

Comments

Andrew Tropin Dec. 25, 2022, 9:11 a.m. UTC | #1
On 2022-12-11 08:56, Artyom V. Poptsov wrote:

> Hello,
>
> it seems that the FreeCAD package hash is incorrect as when I try to
> build the package I get the following error:
>
> --8<---------------cut here---------------start------------->8---
> building /gnu/store/xfaipns1rr4l4zmkc5p4q0ikd0r6srz6-freecad-0.20.2-checkout.drv...
> \r:sha256 hash mismatch for /gnu/store/3lf0plqrf3rwcvd2vlkwaxcc997mivl0-freecad-0.20.2-checkout:
>   expected hash: 02976k91ypv41rqdl27jbmyhnhgx7k5bj520lcqs8qzgcdsynd03
>   actual hash:   0wsfz2jqfhmqshyr1n4qxcc3c6a96gyll4h34vn2zzvvcnncn9rb
> hash mismatch for store item '/gnu/store/3lf0plqrf3rwcvd2vlkwaxcc997mivl0-freecad-0.20.2-checkout'
> build of /gnu/store/xfaipns1rr4l4zmkc5p4q0ikd0r6srz6-freecad-0.20.2-checkout.drv failed
> View build log at '/var/log/guix/drvs/xf/aipns1rr4l4zmkc5p4q0ikd0r6srz6-freecad-0.20.2-checkout.drv.gz'.
> cannot build derivation `/gnu/store/nv4ij1q5106bjv6mpsr2bincifbvynad-freecad-0.20.2.drv': 1 dependencies couldn't be built
> guix upgrade: error: build of `/gnu/store/nv4ij1q5106bjv6mpsr2bincifbvynad-freecad-0.20.2.drv' failed
> --8<---------------cut here---------------end--------------->8---
>
> Here's a patch that fixes the hash.
> From 7916303b93a535cada4202c70d9f4a8fa6653f96 Mon Sep 17 00:00:00 2001
> From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
> Date: Sun, 11 Dec 2022 08:19:29 +0300
> Subject: [PATCH] gnu: freecad: Fix the package hash.
>
> * gnu/packages/engineering.scm (freecad): Fix the package hash.
> ---
>  gnu/packages/engineering.scm | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
> index ee224ad173..3f99113d22 100644
> --- a/gnu/packages/engineering.scm
> +++ b/gnu/packages/engineering.scm
> @@ -2437,7 +2437,7 @@ (define-public freecad
>               (commit version)))
>         (file-name (git-file-name name version))
>         (sha256
> -        (base32 "02976k91ypv41rqdl27jbmyhnhgx7k5bj520lcqs8qzgcdsynd03"))))
> +        (base32 "0wsfz2jqfhmqshyr1n4qxcc3c6a96gyll4h34vn2zzvvcnncn9rb"))))
>      (build-system qt-build-system)
>      (native-inputs
>       (list doxygen
> -- 
> 2.34.1
>
>
> Thanks,
> - avp

Thank you for the patch, applied, pushed as 860e949896:
https://git.savannah.gnu.org/cgit/guix.git/commit/?id=860e949896
diff mbox series

Patch

From 7916303b93a535cada4202c70d9f4a8fa6653f96 Mon Sep 17 00:00:00 2001
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Sun, 11 Dec 2022 08:19:29 +0300
Subject: [PATCH] gnu: freecad: Fix the package hash.

* gnu/packages/engineering.scm (freecad): Fix the package hash.
---
 gnu/packages/engineering.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index ee224ad173..3f99113d22 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -2437,7 +2437,7 @@  (define-public freecad
              (commit version)))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "02976k91ypv41rqdl27jbmyhnhgx7k5bj520lcqs8qzgcdsynd03"))))
+        (base32 "0wsfz2jqfhmqshyr1n4qxcc3c6a96gyll4h34vn2zzvvcnncn9rb"))))
     (build-system qt-build-system)
     (native-inputs
      (list doxygen
-- 
2.34.1