diff mbox series

bug#64199: [PATCH] gnu: Add firejail.

Message ID 87wmyxjug6.fsf_-_@gnu.org
State New
Headers show
Series bug#64199: [PATCH] gnu: Add firejail. | expand

Commit Message

Ludovic Courtès July 18, 2023, 12:05 p.m. UTC
kiasoc5 <kiasoc5@disroot.org> skribis:

> Forgot to add apparmor use-module.
>
> * gnu/packages/linux.scm (firejail): New variable.

Hi! Applied with the changes below (‘gpl2+’ because source code headers
carry the “or any later version” wording).

Thanks,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 18c69d8a61..39503de6ff 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -10172,9 +10172,9 @@  (define-public firejail
     (version "0.9.72")
     (source (origin
               (method url-fetch)
-              (uri (string-append "https://github.com/netblue30/firejail/releases/download/" version
-                                  "/firejail-" version
-                                  ".tar.xz" ))
+              (uri (string-append
+                    "https://github.com/netblue30/firejail/releases/download/" version
+                    "/firejail-" version ".tar.xz" ))
               (sha256
                (base32
                 "1x77xy1mwfgjrcsymdda82bjnqgl7z2yymcb10mzd1zwik27gqc2"))))
@@ -10191,9 +10191,16 @@  (define-public firejail
      (list apparmor xdg-dbus-proxy))
     (synopsis "Linux namespaces sandbox program")
     (description
-     "Firejail is a SUID sandbox program that reduces the risk of security breaches by restricting the running environment of untrusted applications using Linux namespaces, seccomp-bpf and Linux capabilities.  The software includes sandbox profiles for a number of common Linux programs.  Firejail should be added to the list of setuid programs in the system configuration to work properly.")
+     "Firejail is a SUID sandbox program that reduces the risk of security
+breaches by restricting the running environment of untrusted applications
+using Linux namespaces, seccomp-bpf and Linux capabilities.  The software
+includes sandbox profiles for a number of common Linux programs.  Firejail
+should be added to the list of setuid programs in the system configuration to
+work properly.")
     (home-page "https://github.com/netblue30/firejail")
-    (license license:gpl2)))
+    (supported-systems
+     (filter (cut string-suffix? "-linux" <>) %supported-systems))
+    (license license:gpl2+)))
 
 (define-public edac-utils
   (package