diff mbox series

[bug#64702] : Update sbcl-lisp-unit2 to 0.9.4-0.b5aa17b

Message ID 87wmyx1lxf.fsf@gmail.com
State New
Headers show
Series [bug#64702] : Update sbcl-lisp-unit2 to 0.9.4-0.b5aa17b | expand

Commit Message

André A. Gomes July 18, 2023, 11:47 a.m. UTC
Hi Guix,

Patch attached.

Comments

Guillaume Le Vaillant July 19, 2023, 7:47 a.m. UTC | #1
Patch applied as 54a49cf1ccc9d2cf44e5de5bdd0ce5fc7c810fb0.
Thanks.
diff mbox series

Patch

From abb21f2f12584a4b00f6cc60e76f39a764059deb Mon Sep 17 00:00:00 2001
From: "Andre A. Gomes" <andremegafone@gmail.com>
Date: Tue, 18 Jul 2023 12:10:13 +0300
Subject: [PATCH 3/5] gnu: sbcl-lisp-unit2: Update to 0.9.4-0.b5aa17b.

* gnu/packages/lisp-check.scm (sbcl-lisp-unit2): Update to 0.9.4-0.b5aa17b.
---
 gnu/packages/lisp-check.scm | 46 +++++++++++++++++++------------------
 1 file changed, 24 insertions(+), 22 deletions(-)

diff --git a/gnu/packages/lisp-check.scm b/gnu/packages/lisp-check.scm
index 4b18f79a44..6bade26aea 100644
--- a/gnu/packages/lisp-check.scm
+++ b/gnu/packages/lisp-check.scm
@@ -9,7 +9,7 @@ 
 ;;; Copyright © 2021, 2023 Sharlatan Hellseher <sharlatanus@gmail.com>
 ;;; Copyright © 2021 Charles Jackson <charles.b.jackson@protonmail.com>
 ;;; Copyright © 2022 jgart <jgart@dismail.de>
-;;; Copyright © 2022 André A. Gomes <andremegafone@gmail.com>
+;;; Copyright © 2022, 2023 André A. Gomes <andremegafone@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -696,29 +696,31 @@  (define-public ecl-lisp-unit
 (define-public sbcl-lisp-unit2
   ;; There is a cyclical dependency between symbol-munger and lisp-unit2.
   ;; See https://github.com/AccelerationNet/symbol-munger/issues/4
-  (package
-    (name "sbcl-lisp-unit2")
-    (version "0.9.4")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/AccelerationNet/lisp-unit2")
-             (commit version)))
-       (file-name (git-file-name "cl-lisp-unit2" version))
-       (sha256
-        (base32 "0dnq0qvbsn7ciknvmwzfjnimlzq1gdkv5xd87agmhxm1cpm1ksz0"))))
-    (build-system asdf-build-system/sbcl)
-    (inputs
-     (list sbcl-alexandria sbcl-cl-interpol sbcl-iterate
-           sbcl-symbol-munger))
-    (synopsis "Test Framework for Common Lisp")
-    (description
-     "LISP-UNIT2 is a Common Lisp library that supports unit testing in the
+  (let ((commit "b5aa17b298cf2f669f4c0262c471e1ee4ab4699a")
+        (revision "0"))
+    (package
+      (name "sbcl-lisp-unit2")
+      (version (git-version "0.9.4" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/AccelerationNet/lisp-unit2")
+               (commit commit)))
+         (file-name (git-file-name "cl-lisp-unit2" version))
+         (sha256
+          (base32 "140nn22n1xv3qaash3x6h2h7xmys44s3f42b7bakfhpc4qlx0b69"))))
+      (build-system asdf-build-system/sbcl)
+      (inputs
+       (list sbcl-alexandria sbcl-cl-interpol sbcl-iterate
+             sbcl-symbol-munger))
+      (synopsis "Test Framework for Common Lisp")
+      (description
+       "LISP-UNIT2 is a Common Lisp library that supports unit testing in the
 style of JUnit for Java.  It is a new version of the lisp-unit library written
 by Chris Riesbeck.")
-    (home-page "https://github.com/AccelerationNet/lisp-unit2")
-    (license license:expat)))
+      (home-page "https://github.com/AccelerationNet/lisp-unit2")
+      (license license:expat))))
 
 (define-public cl-lisp-unit2
   (sbcl-package->cl-source-package sbcl-lisp-unit2))
-- 
2.41.0