diff mbox series

[bug#65012] gnu: Add picket.

Message ID 87wmwwpeq5.fsf_-_@gnu.org
State New
Headers show
Series [bug#65012] gnu: Add picket. | expand

Commit Message

Ludovic Courtès Sept. 11, 2023, 9:44 p.m. UTC
Sergio Pastor Pérez <sergio.pastorperez@outlook.es> skribis:

> * gnu/packages/image.scm (picket): New variable.

Applied with the changes below.

Thanks!
diff mbox series

Patch

diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 480335d704..4332a7ead8 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -1996,17 +1996,19 @@  (define-public picket
                               (("/usr")
                                #$output))))
                         (add-after 'unpack 'fix-cmake-paths
-                          (lambda _
+                          (lambda* (#:key inputs #:allow-other-keys)
                             (substitute* "CMakeLists.txt"
                               (("src/cfg/ini.h")
-                               (string-append #$mini "/include/mini/ini.h"))
+                               (search-input-file inputs
+                                                  "/include/mini/ini.h"))
                               (("/usr/")
                                #$output)))))))
     (build-system cmake-build-system)
     (home-page "https://github.com/rajter/picket")
-    (synopsis "Native linux screen color picker with custom format output")
+    (synopsis "Screen color picker with custom format output")
     (description
-     "Screen color picker for linux with magnifier and custom/user defined formats.")
+     "Picket is a screen color picker that includes a magnifier and supports
+custom formats for representing color values..")
     (license license:gpl3+)))
 
 (define-public gpick