diff mbox series

[bug#67258] gnu: python-pytest-perf: Update to 0.13.1.

Message ID 87wmufl55z.fsf@troyfigiel.com
State New
Headers show
Series [bug#67258] gnu: python-pytest-perf: Update to 0.13.1. | expand

Commit Message

Troy Figiel Nov. 18, 2023, 10:36 a.m. UTC
* gnu/packages/check.scm (python-pytest-perf): Update to 0.13.1.
[build-system]: Switch to pyproject-build-system, because setup.py has been removed since 0.12.1.
[arguments]<#:phases>: Remove ignored tests from the check phase.
<#:test-flags>: And use test flags instead.

Change-Id: Id81e47666a51b411740c6e6a6f6976cee616b6a4
---
 gnu/packages/check.scm | 33 ++++++++++++++-------------------
 1 file changed, 14 insertions(+), 19 deletions(-)

Comments

jgart Nov. 18, 2023, 2:39 p.m. UTC | #1
Thanks Troy! Applied.
diff mbox series

Patch

diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index cf26196a24..1f5b886977 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -2551,7 +2551,7 @@  (define-public python-pytest-pep8
 (define-public python-pytest-perf
   (package
     (name "python-pytest-perf")
-    (version "0.12.0")
+    (version "0.13.1")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -2560,26 +2560,21 @@  (define-public python-pytest-perf
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "05mgknvrmyz1kmkgw8jzvisavc68wz1g2wxv69i6xvzgqxf17m9f"))))
-    (build-system python-build-system)
+                "1hrccvrbccqwba04pqj749hdzn4sgldmbpg74nf3fzz7wyg6jxqk"))))
+    (build-system pyproject-build-system)
     (arguments
      (list
-      #:phases
-      #~(modify-phases %standard-phases
-          (replace 'check
-            (lambda* (#:key tests? #:allow-other-keys)
-              (when tests?
-                (invoke "pytest" "-k"
-                        (string-append
-                         ;; Do not test the myproject.toml build as it tries to pull
-                         ;; dependencies from the internet.
-                         "not project "
-                         ;; The benchmark test attempts to install the
-                         ;; package, failing to pull its dependencies from the
-                         ;; network.
-                         "and not BenchmarkRunner "
-                         ;; The upstream_url test requires networking.
-                         "and not upstream_url"))))))))
+      #:test-flags '(list "-k"
+                          (string-append
+                           ;; Do not test the myproject.toml build as it tries to pull
+                           ;; dependencies from the internet.
+                           "not project "
+                           ;; The benchmark test attempts to install the
+                           ;; package, failing to pull its dependencies from the
+                           ;; network.
+                           "and not BenchmarkRunner "
+                           ;; The upstream_url test requires networking.
+                           "and not upstream_url"))))
     (native-inputs
      (list python-pytest
            python-pytest-black