diff mbox series

bug#68965: [PATCH] gnu: Add yambar-wayland.

Message ID 87wmqqgq23.fsf@gnu.org
State New
Headers show
Series bug#68965: [PATCH] gnu: Add yambar-wayland. | expand

Commit Message

Ludovic Courtès Feb. 27, 2024, 10:27 a.m. UTC
chris <chris@bumblehead.com> skribis:

> *  (yambar-wayland): New variable.
>
> Change-Id: I7b1d5d3626b915261b5b3f7fea3a3ace03adbf11

I tweaked the commit log and applied with the cosmetic changes below.

Thanks!

Ludo'.
diff mbox series

Patch

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 54ffe0599d..ae8213ddae 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -3609,21 +3609,24 @@  (define-public yambar-wayland
       #:configure-flags #~'("-Db_lto=true"
                             "-Dbackend-x11=disabled"
                             "-Dbackend-wayland=enabled")))
-    (native-inputs (list pkg-config tllist flex bison scdoc wayland-protocols))
-    (inputs (list
-             fcft
-             wayland
-             pipewire
-             libyaml
-             pixman
-             alsa-lib
-             json-c
-             libmpdclient
-             eudev))
+    (native-inputs (list pkg-config
+                         tllist
+                         flex
+                         bison
+                         scdoc
+                         wayland-protocols))
+    (inputs (list fcft
+                  wayland
+                  pipewire
+                  libyaml
+                  pixman
+                  alsa-lib
+                  json-c
+                  libmpdclient
+                  eudev))
     (synopsis "X11 and Wayland status panel")
     (description
-     "@command{yambar} is a lightweight and configurable status
- panel (bar, for short) for X11 and Wayland, that goes to great
- lengths to be both CPU and battery efficient - polling is only
- done when absolutely necessary.")
+     "@command{yambar} is a lightweight and configurable status panel (bar,
+for short) for X11 and Wayland, that goes to great lengths to be both CPU and
+battery efficient---polling is only done when absolutely necessary.")
     (license license:expat)))