diff mbox series

[bug#69514] gnu: python-pandera: Update to 0.18.0.

Message ID 87wmqkpcuq.fsf@troyfigiel.com
State New
Headers show
Series [bug#69514] gnu: python-pandera: Update to 0.18.0. | expand

Commit Message

Troy Figiel March 2, 2024, 8:46 p.m. UTC
* gnu/packages/python-science.scm (python-pandera): Update to 0.18.0.
[source]: Remove snippet.
[arguments]<#:phases>: Add 'fix-tests phase.
---
 gnu/packages/python-science.scm | 22 ++++++++++++----------
 1 file changed, 12 insertions(+), 10 deletions(-)


base-commit: 6f5ea7ac1acb3d1c53baf7620cca66cc87fe5a73

Comments

Vagrant Cascadian March 9, 2024, 6:44 a.m. UTC | #1
On 2024-03-02, Troy Figiel wrote:
> diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
> index b6a116f16b..93b5c5c91d 100644
> --- a/gnu/packages/python-science.scm
> +++ b/gnu/packages/python-science.scm
...
> @@ -836,14 +836,7 @@ (define-public python-pandera
>               (commit (string-append "v" version))))
>         (file-name (git-file-name name version))
>         (sha256
> -        (base32 "1mnqk583z90k1n0z3lfa4rd0ng40v7hqfk7phz5gjmxlzfjbxa1x"))
> -       (modules '((guix build utils)))
> -       ;; These tests require PySpark and Modin. We need to remove the entire
> -       ;; directory, since the conftest.py in these directories contain
> -       ;; imports.  (See: https://github.com/pytest-dev/pytest/issues/7452)
> -       (snippet '(begin
> -                   (delete-file-recursively "tests/pyspark")
> -                   (delete-file-recursively "tests/modin")))))
> +        (base32 "14b5aij5zjkwvsimg0v00qvp59mhhq7ljim4qghcn432vkg9gh47"))))
>      (build-system pyproject-build-system)
>      (arguments
>       (list
> @@ -854,7 +847,16 @@ (define-public python-pandera
>                             ;; positives. These tests currently fail.
>                             "not test_python_std_list_dict_generics"
>                             " and not test_python_std_list_dict_empty_and_none"
> -                           " and not test_pandas_modules_importable"))))
> +                           " and not test_pandas_modules_importable"))
> +      #:phases #~(modify-phases %standard-phases
> +                   (add-before 'check 'fix-tests
> +                     (lambda _
> +                       ;; These tests require PySpark and Modin. We need to
> +                       ;; remove the entire directory, since the conftest.py
> +                       ;; in these directories contain imports.  (See:
> +                       ;; https://github.com/pytest-dev/pytest/issues/7452)
> +                       (for-each delete-file-recursively
> +                                 '("tests/pyspark" "tests/modin")))))))
>      ;; Pandera comes with a lot of extras. We test as many as possible, but do
>      ;; not include all of them in the propagated-inputs. Currently, we have to
>      ;; skip the pyspark and io tests due to missing packages python-pyspark

Any compelling reason why the test removal should be moved from a
snippet to a phase? The documentation admits to this being an elusive
distinction, not really clearing things up much:

  https://guix.gnu.org/en/manual/devel/en/guix.html#Snippets-versus-Phases

Other than that, this looks like a trivial version bump. :)

Builds fine, no dependents...

live well,
  vagrant
Troy Figiel March 9, 2024, 8:50 a.m. UTC | #2
Hi vagrant,

On 2024-03-09 07:44, Vagrant Cascadian wrote:
> Any compelling reason why the test removal should be moved from a
> snippet to a phase? The documentation admits to this being an elusive
> distinction, not really clearing things up much:
> 

I read the following as stating we should keep any source code that
could be used to build the package on different systems, including tests
that could be run on other systems:

--8<---------------cut here---------------start------------->8---
The source derived from an origin should produce a source that can be
used to build the package on any system that the upstream package
supports (i.e., act as the corresponding source).
--8<---------------cut here---------------end--------------->8---

Other than that, no reason and either would be fine in my opinion. The
current documentation is more confusing rather than enlightening in this
case.

Best wishes,

Troy
diff mbox series

Patch

diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index b6a116f16b..93b5c5c91d 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -826,7 +826,7 @@  (define-public python-pandarallel
 (define-public python-pandera
   (package
     (name "python-pandera")
-    (version "0.17.2")
+    (version "0.18.0")
     (source
      (origin
        ;; No tests in the PyPI tarball.
@@ -836,14 +836,7 @@  (define-public python-pandera
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1mnqk583z90k1n0z3lfa4rd0ng40v7hqfk7phz5gjmxlzfjbxa1x"))
-       (modules '((guix build utils)))
-       ;; These tests require PySpark and Modin. We need to remove the entire
-       ;; directory, since the conftest.py in these directories contain
-       ;; imports.  (See: https://github.com/pytest-dev/pytest/issues/7452)
-       (snippet '(begin
-                   (delete-file-recursively "tests/pyspark")
-                   (delete-file-recursively "tests/modin")))))
+        (base32 "14b5aij5zjkwvsimg0v00qvp59mhhq7ljim4qghcn432vkg9gh47"))))
     (build-system pyproject-build-system)
     (arguments
      (list
@@ -854,7 +847,16 @@  (define-public python-pandera
                            ;; positives. These tests currently fail.
                            "not test_python_std_list_dict_generics"
                            " and not test_python_std_list_dict_empty_and_none"
-                           " and not test_pandas_modules_importable"))))
+                           " and not test_pandas_modules_importable"))
+      #:phases #~(modify-phases %standard-phases
+                   (add-before 'check 'fix-tests
+                     (lambda _
+                       ;; These tests require PySpark and Modin. We need to
+                       ;; remove the entire directory, since the conftest.py
+                       ;; in these directories contain imports.  (See:
+                       ;; https://github.com/pytest-dev/pytest/issues/7452)
+                       (for-each delete-file-recursively
+                                 '("tests/pyspark" "tests/modin")))))))
     ;; Pandera comes with a lot of extras. We test as many as possible, but do
     ;; not include all of them in the propagated-inputs. Currently, we have to
     ;; skip the pyspark and io tests due to missing packages python-pyspark