diff mbox series

[bug#36353] Acknowledgement ((no subject))

Message ID 87v9wvw3i7.fsf@odyssey.lafreniere.xyz
State Accepted
Headers show
Series [bug#36353] Acknowledgement ((no subject)) | expand

Commit Message

LaFreniere, Joseph June 24, 2019, 12:51 p.m. UTC
I intended to attach the patch with the subject "[PATCH] gnu: Add 
emacs-minions."  Please find the corrected patch attached to this 
mail.

I apologize for the inconvenience;  I am still fighting with my 
mail setup to correctly send Git patches.

--
Joseph LaFreniere

Comments

swedebugia June 24, 2019, 5:43 p.m. UTC | #1
On 2019-06-24 14:51, LaFreniere, Joseph wrote:
> I intended to attach the patch with the subject "[PATCH] gnu: Add 
> emacs-minions."  Please find the corrected patch attached to this mail.
> 
> I apologize for the inconvenience;  I am still fighting with my mail 
> setup to correctly send Git patches.

None needed :)

Thanks for the patch! LGTM.
Ludovic Courtès July 2, 2019, 10:33 p.m. UTC | #2
Hi Joseph,

"LaFreniere, Joseph" <joseph@lafreniere.xyz> skribis:

>>From e7980e5e582d937301ea5fe0d76f57360cadc0ed Mon Sep 17 00:00:00 2001
> From: Joseph LaFreniere <joseph@lafreniere.xyz>
> Date: Sun, 23 Jun 2019 02:53:22 -0500
> Subject: [PATCH] gnu: Add emacs-minions.
> To: guix-patches@gnu.org
>
> * gnu/packages/emacs-xyz.scm (emacs-minions): New variable.

Applied, thanks!

Ludo’.
diff mbox series

Patch

From e7980e5e582d937301ea5fe0d76f57360cadc0ed Mon Sep 17 00:00:00 2001
From: Joseph LaFreniere <joseph@lafreniere.xyz>
Date: Sun, 23 Jun 2019 02:53:22 -0500
Subject: [PATCH] gnu: Add emacs-minions.
To: guix-patches@gnu.org

* gnu/packages/emacs-xyz.scm (emacs-minions): New variable.
---
 gnu/packages/emacs-xyz.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 238b204b3c..bc261130b8 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -433,6 +433,38 @@  these arguments.  The prototypical use is for the command to call an external
 process, passing on the arguments as command line arguments.")
     (license license:gpl3+)))
 
+(define-public emacs-minions
+  (package
+    (name "emacs-minions")
+    (version "0.3.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/tarsius/minions.git")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0q2y37zfxlbfvgdn70ikg3abp8vljna4ir9nyqlz1awmz5i1c43s"))))
+    (build-system emacs-build-system)
+    (propagated-inputs
+     `(("emacs-dash" ,emacs-dash)))
+    (home-page "https://github.com/tarsius/minions")
+    (synopsis "Minor-mode menu for the mode line")
+    (description
+     "This package implements a menu that lists enabled minor-modes, as well
+as commonly but not currently enabled minor-modes.  It can be used to toggle
+local and global minor-modes, to access mode-specific menus, and to get help
+about modes.
+
+This menu is intended as a replacement for the incomplete yet wide list of
+enabled minor-modes that is displayed in the mode line by default.  To use the
+menu like this, enable Minions mode.
+
+Alternatively the menu can be bound globally, for example:
+@code{(global-set-key [S-down-mouse-3] 'minions-minor-modes-menu)}.")
+    (license license:gpl3+)))
+
 (define-public emacs-treepy
   (package
     (name "emacs-treepy")
-- 
2.22.0