diff mbox series

[bug#39384] gnu: Add emacs-rg.

Message ID 87v9oqrr0q.fsf@lafreniere.xyz
State Accepted
Headers show
Series [bug#39384] gnu: Add emacs-rg. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

LaFreniere, Joseph Feb. 1, 2020, 8:28 p.m. UTC
Patch file is attached to package 
https://github.com/dajva/rg.el.git.

--
Joseph LaFreniere

Comments

Nicolas Goaziou Feb. 1, 2020, 10:09 p.m. UTC | #1
Hello,

"LaFreniere, Joseph" <joseph@lafreniere.xyz> writes:

> Patch file is attached to package https://github.com/dajva/rg.el.git.

Thank you! Some comments follow.

> +       (sha256
> +        (base32
> +         "0k7x5z7mh9flwih35cqy8chs54rack3nswdcpw5wcpgv6xim227y"))))

Nitpick: I think the trend is to align `base32' with the string.

> +    (build-system emacs-build-system)
> +    (propagated-inputs
> +     `(("emacs-s" ,emacs-s)
> +       ("emacs-wgrep" ,emacs-wgrep)
> +       ("ripgrep" ,ripgrep)))
> +    (home-page "https://rgel.readthedocs.io/en/latest/")
> +    (synopsis "A search tool based on @code{ripgrep}")

You may want to lint your package. In particular, the synopsis should be
akin to "Search tool based ..."

> +    (description
> +     "An Emacs search package based on the @code{ripgrep} command line

The description must start with a full sentence, e.g., "rg.el" is an
Emacs search package...

> +tool. It allows you to interactively create searches, doing automatic searches

Texinfo requires two spaces after the full stop.

> +based on the editing context, refining and modifying search results and much
> +more. It is also highly configurable to be able to fit different users’

Ditto. Besides, the quote after "users" looks suspicious. You should use
a regular quote.

Could you send an updated patch?

Regards,
diff mbox series

Patch

From d3e76096a6c44764d51ef06aedb171682f92c85e Mon Sep 17 00:00:00 2001
From: Joseph LaFreniere <joseph@lafreniere.xyz>
Date: Sat, 1 Feb 2020 14:23:36 -0600
Subject: [PATCH] gnu: Add emacs-rg.

* gnu/packages/emacs-xyz.scm (emacs-rg): New variable.
---
 gnu/packages/emacs-xyz.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index f95ad26e4b..c8b87ce712 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -2751,6 +2751,35 @@  column by drawing a thin line down the length of the editing window.")
      "This Emacs package allows managing multiple grep buffers.")
     (license license:gpl3+)))
 
+(define-public emacs-rg
+  (package
+    (name "emacs-rg")
+    (version "1.8.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/dajva/rg.el.git")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "0k7x5z7mh9flwih35cqy8chs54rack3nswdcpw5wcpgv6xim227y"))))
+    (build-system emacs-build-system)
+    (propagated-inputs
+     `(("emacs-s" ,emacs-s)
+       ("emacs-wgrep" ,emacs-wgrep)
+       ("ripgrep" ,ripgrep)))
+    (home-page "https://rgel.readthedocs.io/en/latest/")
+    (synopsis "A search tool based on @code{ripgrep}")
+    (description
+     "An Emacs search package based on the @code{ripgrep} command line
+tool. It allows you to interactively create searches, doing automatic searches
+based on the editing context, refining and modifying search results and much
+more. It is also highly configurable to be able to fit different users’
+needs.")
+    (license license:gpl3+)))
+
 (define-public emacs-inf-ruby
   (package
     (name "emacs-inf-ruby")
-- 
2.25.0