diff mbox series

[bug#39963] fd bash_completion typo

Message ID 87v9nh116x.fsf@rohleder.de
State Accepted
Headers show
Series [bug#39963] fd bash_completion typo | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Michael Rohleder March 7, 2020, 12:03 a.m. UTC
Hey guix!

* The "fd" package installs its bash_completion file in the wrong directory.

Comments

Maja Kądziołka March 7, 2020, 6:05 p.m. UTC | #1
On Sat, Mar 07, 2020 at 01:03:02AM +0100, mike@rohleder.de wrote:
> Hey guix!
> 
> * The "fd" package installs its bash_completion file in the wrong directory.
> 

Thanks! I added a copyright line for you, wrote a commit message and
pushed to master as commit 9eed0a74f92ed4e1b631f4658d98a5f46ad1664d

Regards,
Jakub Kądziołka
diff mbox series

Patch

diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index 72c982f23c..ce50562228 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -184,11 +184,11 @@  also knows about symlinks, extended attributes, and Git.")
                ;; Manpages
                (install-file "doc/fd.1" (string-append out "/share/man/man1"))
                ;; Completions
-               (install-completion "^fd.bash$" "/etc/bash-completion.d")
+               (install-completion "^fd.bash$" "/etc/bash_completion.d")
                (install-completion "^fd.fish$" "/share/fish/vendor_completions.d")
                (install-completion "^_fd$" "/share/zsh/site-functions")
-               (rename-file (string-append out "/etc/bash-completion.d/fd.bash")
-                            (string-append out "/etc/bash-completion.d/fd"))
+               (rename-file (string-append out "/etc/bash_completion.d/fd.bash")
+                            (string-append out "/etc/bash_completion.d/fd"))
                #t))))))
     (inputs `(("jemalloc" ,jemalloc)))
     (home-page "https://github.com/sharkdp/fd")