diff mbox series

[bug#40128,2/2] gnu: Add emacs-major-mode-hydra.

Message ID 87v9mxl2s0.fsf@lafreniere.xyz
State Accepted
Headers show
Series None | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

LaFreniere, Joseph March 21, 2020, 11:13 p.m. UTC
Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:

>> +    (arguments
>> +     `(#:phases
>> +       (modify-phases %standard-phases
>> +         (add-before 'add-source-to-load-path 
>> 'remove-pretty-hydra
>> +           (lambda* (#:key outputs #:allow-other-keys)
>> +             ;; pretty-hydra is provided by dependency.
>> +             (delete-file "pretty-hydra.el")
>> +             #t)))))
>
> There, too, you may use #:exclude.

New patch file implemented with #:exclude is attached.  Thank you 
very much for reviewing.

--
Joseph LaFreniere
diff mbox series

Patch

From 5ec5117c0cda5c69d3210a93243c060ea2930c5a Mon Sep 17 00:00:00 2001
From: Joseph LaFreniere <joseph@lafreniere.xyz>
Date: Wed, 18 Mar 2020 20:59:09 -0500
Subject: [PATCH 2/2] gnu: Add emacs-major-mode-hydra.

* gnu/packages/emacs-xyz.scm (emacs-major-mode-hydra): New variable.

gnu: Add emacs-major-mode-hydra.

* gnu/packages/emacs-xyz.scm (emacs-major-mode-hydra): New variable.
---
 gnu/packages/emacs-xyz.scm | 14 ++++++++++++++
 1 file changed, 14 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 50eec6d516..7056f0227b 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -5514,6 +5514,20 @@  mode-specific key bindings.  It is intended for use as a library only; see
 package @code{emacs-major-mode-hydra} for a user-friendly interface.")
     (license license:gpl3+)))
 
+(define-public emacs-major-mode-hydra
+  (package
+    (inherit emacs-pretty-hydra)
+    (name "emacs-major-mode-hydra")
+    (propagated-inputs
+     `(("emacs-dash" ,emacs-dash)
+       ("emacs-pretty-hydra" ,emacs-pretty-hydra)))
+    (arguments
+     `(#:exclude (cons "^pretty-hydra\\.el" %default-exclude)))
+    (synopsis "Create nice-looking hydras")
+    (description
+     "This package provides the macro @code{pretty-hydra-define} to define
+hydras with one column per group of heads.")))
+
 (define-public emacs-ivy
   (package
     (name "emacs-ivy")
-- 
2.25.1