diff mbox series

[bug#44024] gnu: emacs-request: Update to latest commit.

Message ID 87v9f78iki.fsf@posteo.net
State Accepted
Headers show
Series [bug#44024] gnu: emacs-request: Update to latest commit. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Niklas Eklund Oct. 18, 2020, 7:01 p.m. UTC
Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:

> Hello,
>
> Niklas Eklund <niklas.eklund@posteo.net> writes:
>
>> This patch updates emacs-request to the latest commit on git. The reason for
>> updating the package is that early this year a patch was merged which allowed
>> emacs-request to utilize the auth-source package providing a more convenient
>> experience for users and package developers.
>
> Thank you.
>
> Could you add a comment explaining the above at the top of the package
> definition and send it again?
>
> Regards,
> -- 
> Nicolas Goaziou

Absolutely, I wasn't sure if I were to put it in the code or not, but
now I know for the future.

Cheers,
Niklas

Comments

Ludovic Courtès Nov. 18, 2020, 10:09 p.m. UTC | #1
Hi,

Niklas Eklund <niklas.eklund@posteo.net> skribis:

> Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:
>
>> Hello,
>>
>> Niklas Eklund <niklas.eklund@posteo.net> writes:
>>
>>> This patch updates emacs-request to the latest commit on git. The reason for
>>> updating the package is that early this year a patch was merged which allowed
>>> emacs-request to utilize the auth-source package providing a more convenient
>>> experience for users and package developers.
>>
>> Thank you.
>>
>> Could you add a comment explaining the above at the top of the package
>> definition and send it again?
>>
>> Regards,
>> -- 
>> Nicolas Goaziou
>
> Absolutely, I wasn't sure if I were to put it in the code or not, but
> now I know for the future.

[...]

> +(define-public emacs-gcmh
> +  (let ((commit "84c43a4c0b41a595ac6e299fa317d2831813e580")
> +        (revision "0"))

Looks like you forgot the comment.  :-)

Could you send an updated patch?  (Else we can do it for you.)

Thanks,
Ludo’.
diff mbox series

Patch

From 0feb4bd289c7bab7b82e4d2f37fc7247acda6f6e Mon Sep 17 00:00:00 2001
From: Niklas Eklund <niklas.eklund@posteo.net>
Date: Wed, 30 Sep 2020 15:34:36 +0200
Subject: [PATCH v2] gnu: Add emacs-gcmh.

* gnu/packages/emacs-xyz.scm (emacs-gcmh): New variable.
---
 gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 13471f77d1..575ee25308 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -1768,6 +1768,31 @@  always indented.  It reindents after every change, making it more reliable
 than @code{electric-indent-mode}.")
     (license license:gpl2+)))
 
+(define-public emacs-gcmh
+  (let ((commit "84c43a4c0b41a595ac6e299fa317d2831813e580")
+        (revision "0"))
+    (package
+      (name "emacs-gcmh")
+      (version (git-version "0.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://gitlab.com/koral/gcmh")
+               (commit commit)))
+         (sha256
+          (base32 "1r3wiqhrzh7wvqy484nl031fd4bn4cpvkv9646s4cjgvnnnv7jz3"))
+         (file-name (git-file-name name version))))
+      (build-system emacs-build-system)
+      (home-page "https://gitlab.com/koral/gcmh")
+      (synopsis "Emacs Garbage Collector Magic Hack")
+      (description
+       "This package enforces a sneaky @dfn{garbage collector} (GC) strategy
+to minimize GC interference with the activity.  During normal use a high GC
+threshold is set.  When idling GC is immediately triggered and a low threshold
+is set.")
+      (license license:gpl3+))))
+
 (define-public emacs-ctrlf
   (package
     (name "emacs-ctrlf")
-- 
2.28.0