diff mbox series

[bug#50333] Fixed missing files in org-roam 2.1.0

Message ID 87v93icnst.fsf@unanue.mx
State Accepted
Headers show
Series [bug#50333] Fixed missing files in org-roam 2.1.0 | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Adolfo De Unánue Sept. 3, 2021, 3:57 a.m. UTC
Wrong patch! (I am so sorry for this, my first time with this 
workflow)
--
- A

Comments

Simon Tournier Sept. 14, 2021, 12:26 p.m. UTC | #1
Hi,

You are asking in <http://issues.guix.gnu.org/issue/50374> about this
one.  Well, I am not an expert and I am not an Emacs Roam user.

On Thu, 02 Sep 2021 at 22:57, Adolfo De Unánue <adolfo@unanue.mx> wrote:

>>From a99fa75c0f5d3025827d99c3ef6a2c71c85e0be5 Mon Sep 17 00:00:00 2001
> From: =?UTF-8?q?Adolfo=20De=20Un=C3=A1nue?= <adolfo+git@unanue.mx>
> Date: Thu, 2 Sep 2021 22:23:58 -0500
> Subject: [PATCH] Fixed missing files in org-roam v2.1.0

The commit message should be:

--8<---------------cut here---------------start------------->8---
gnu: emacs-org-roam: Adding extensions.

* guix/emacs-xyz.scm (emacs-org-roam)[arguments]: Add phases to install
extensions.
--8<---------------cut here---------------end--------------->8---

Or something along these lines.

> ---
>  gnu/packages/emacs-xyz.scm | 94 +++++++++++++++++++++-----------------
>  1 file changed, 53 insertions(+), 41 deletions(-)
>
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index 030809f5ac..431444c255 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -103,6 +103,7 @@
>  ;;; Copyright © 2021 Matthew James Kraai <kraai@ftbfs.org>
>  ;;; Copyright © 2021 Noisytoot <noisytoot@disroot.org>
>  ;;; Copyright © 2021 Simon South <simon@simonsouth.net>
> +;;; Copyright © 2021 Nanounanue <adolfo@unanue.mx>

Since you submit with this name “Adolfo De Unánue“, the Copyright should
be the same instead of a nick name.  From my point of view, nickname as
copyright holder should be avoided; if possible, obviously. :-)

> +  (let ((commit "f819720c510185af713522c592833ec9f2934251")

Usually, the package uses tagged version instead of random commit.  When
it is not possible because upstream do not tag, it seems good to provide
an explanation why the lasted tagged version cannot be used;
explanations as a comment or in the cover letter.

Another reason is because for instance it changes all the indentation
and makes ‘git log/blame’ harder to investigate.

> +           (add-after 'install 'install-extensions
> +             (lambda* (#:key outputs #:allow-other-keys)
> +               (copy-recursively
> +                "extensions"
> +                (string-append (assoc-ref outputs "out")
> +                               (string-append
> +                                "/share/emacs/site-lisp/org-roam-"
> +                                ,version)))
> +               #t))

Patch#50333 will install the extensions with “guix install
emacs-org-roam”.  Instead the attempt of patch#50374 is to install with
“guix install emacs-org-roam-extensions”.  Well, I do not know if
patch#50374 is correct, though.

Because I am not an Org-Roam user, I do not have an opinion about this
extensions.  Maybe it is better to distribute them along the package
emacs-org-roam or in a separate package, I do not know.  WDYT?

All the best,
simon
Adolfo De Unánue Sept. 14, 2021, 10:10 p.m. UTC | #2
Thank you for your comments and advices.



zimoun <zimon.toutoune@gmail.com> writes:

> Hi,
>
> You are asking in <http://issues.guix.gnu.org/issue/50374> about 
> this
> one.  Well, I am not an expert and I am not an Emacs Roam user.
>
> On Thu, 02 Sep 2021 at 22:57, Adolfo De Unánue 
> <adolfo@unanue.mx> wrote:
>
>>>From a99fa75c0f5d3025827d99c3ef6a2c71c85e0be5 Mon Sep 17 
>>>00:00:00 2001
>> From: =?UTF-8?q?Adolfo=20De=20Un=C3=A1nue?= 
>> <adolfo+git@unanue.mx>
>> Date: Thu, 2 Sep 2021 22:23:58 -0500
>> Subject: [PATCH] Fixed missing files in org-roam v2.1.0
>
> The commit message should be:
>
> --8<---------------cut 
> here---------------start------------->8---
> gnu: emacs-org-roam: Adding extensions.
>
> * guix/emacs-xyz.scm (emacs-org-roam)[arguments]: Add phases to 
> install
> extensions.
> --8<---------------cut 
> here---------------end--------------->8---
>
> Or something along these lines.
>

Should I apply your suggested changes, commit them, use this 
commit
message, create the patch and send them again?

>> ---
>>  gnu/packages/emacs-xyz.scm | 94 
>>  +++++++++++++++++++++-----------------
>>  1 file changed, 53 insertions(+), 41 deletions(-)
>>
>> diff --git a/gnu/packages/emacs-xyz.scm 
>> b/gnu/packages/emacs-xyz.scm
>> index 030809f5ac..431444c255 100644
>> --- a/gnu/packages/emacs-xyz.scm
>> +++ b/gnu/packages/emacs-xyz.scm
>> @@ -103,6 +103,7 @@
>>  ;;; Copyright © 2021 Matthew James Kraai <kraai@ftbfs.org>
>>  ;;; Copyright © 2021 Noisytoot <noisytoot@disroot.org>
>>  ;;; Copyright © 2021 Simon South <simon@simonsouth.net>
>> +;;; Copyright © 2021 Nanounanue <adolfo@unanue.mx>
>
> Since you submit with this name “Adolfo De Unánue“, the 
> Copyright should
> be the same instead of a nick name.  From my point of view, 
> nickname as
> copyright holder should be avoided; if possible, obviously. :-)

I will do, makes complete sense


>
>> +  (let ((commit "f819720c510185af713522c592833ec9f2934251")
>
> Usually, the package uses tagged version instead of random 
> commit.  When
> it is not possible because upstream do not tag, it seems good to 
> provide
> an explanation why the lasted tagged version cannot be used;
> explanations as a comment or in the cover letter.
>

As you guessed, org-roam has not tagged this new (breaking) 
change,
that's why I am using the commit



> Another reason is because for instance it changes all the 
> indentation
> and makes ‘git log/blame’ harder to investigate.
>
>> +           (add-after 'install 'install-extensions
>> +             (lambda* (#:key outputs #:allow-other-keys)
>> +               (copy-recursively
>> +                "extensions"
>> +                (string-append (assoc-ref outputs "out")
>> +                               (string-append
>> +                                "/share/emacs/site-lisp/org-roam-"
>> +                                ,version)))
>> +               #t))
>
> Patch#50333 will install the extensions with “guix install
> emacs-org-roam”.  Instead the attempt of patch#50374 is to 
> install with
> “guix install emacs-org-roam-extensions”.  Well, I do not know 
> if
> patch#50374 is correct, though.
>
> Because I am not an Org-Roam user, I do not have an opinion 
> about this
> extensions.  Maybe it is better to distribute them along the 
> package
> emacs-org-roam or in a separate package, I do not know.  WDYT?
>

I mean, structurally the upstream owner just moved some files to a 
new
folder, my guess is that it shouldn't be a different packages 
since it
is still part of org-roam.


> All the best,
> simon


Again thank you, it was super helpful!

--
- A
Simon Tournier Sept. 15, 2021, 5:03 a.m. UTC | #3
Hi,

On Tue, 14 Sep 2021 at 17:10, Adolfo De Unánue <adolfo@unanue.mx> wrote:
> zimoun <zimon.toutoune@gmail.com> writes:

>>> Subject: [PATCH] Fixed missing files in org-roam v2.1.0
>>
>> The commit message should be:
>>
>> --8<---------------cut  here---------------start------------->8---
>> gnu: emacs-org-roam: Adding extensions.
>>
>> * guix/emacs-xyz.scm (emacs-org-roam)[arguments]: Add phases to 
>> install
>> extensions.
>> --8<---------------cut here---------------end--------------->8---
>>
>> Or something along these lines.
>
> Should I apply your suggested changes, commit them, use this 
> commit
> message, create the patch and send them again?

Yeah, you can address and send then an updated patch.  Doing so, please
increment the re-roll count which eases to know that patch is the last.

For instance, the ones you sent looks like:

--8<---------------cut here---------------start------------->8---
[ Adolfo De Unánue ] [bug#50333] [PATCH] Fixed missing files in org-roam 2.1.0
    [ Adolfo De Unánue ] 
    [ Adolfo De Unánue ] 
--8<---------------cut here---------------end--------------->8---

and the reviewer has to open all 3 to know what happens.  Compare with
for instance:

--8<---------------cut here---------------start------------->8---
[ Marius Bakke ] [bug#50377] [PATCH 0/2] Support 'git describe'  …
    [ Marius Bakke ] [bug#50377] [PATCH 1/2] git: 'resolve-refer …
        [ Marius Bakke ] [bug#50377] [PATCH 2/2] transformations …
        [ Marius Bakke ] [bug#50377] [PATCH v2 1/2] git: 'resolv …
    [ Marius Bakke ] [bug#50377] [PATCH v3 0/2] Support 'git des …
        [ Marius Bakke ] [bug#50377] [PATCH v3 1/2] git: 'resolv …
            [ Ludovic Courtès ] [bug#50377] [PATCH 0/2] Support  …
        [ Marius Bakke ] [bug#50377] [PATCH v3 2/2] transformati …
            [ Ludovic Courtès ] [bug#50377] [PATCH 0/2] Support  …
        [ Xinglu Chen ] [bug#50377] [PATCH v3 0/2] Support 'git  …
--8<---------------cut here---------------end--------------->8---

Well, I suggest you to use “git format-patch -v4”. :-)


>>> +  (let ((commit "f819720c510185af713522c592833ec9f2934251")
>>
>> Usually, the package uses tagged version instead of random 
>> commit.  When
>> it is not possible because upstream do not tag, it seems good to 
>> provide
>> an explanation why the lasted tagged version cannot be used;
>> explanations as a comment or in the cover letter.
>>
>
> As you guessed, org-roam has not tagged this new (breaking) 
> change,
> that's why I am using the commit

Yeah, but is it released?  Or simply the development version?  If it is
the development version, usually it is on per user basis, i.e., you can
use a package transformation.  Inclusion of releases is preferred.

>>> +           (add-after 'install 'install-extensions
>>> +             (lambda* (#:key outputs #:allow-other-keys)
>>> +               (copy-recursively
>>> +                "extensions"
>>> +                (string-append (assoc-ref outputs "out")
>>> +                               (string-append
>>> +                                "/share/emacs/site-lisp/org-roam-"
>>> +                                ,version)))
>>> +               #t))
>>
>> Patch#50333 will install the extensions with “guix install
>> emacs-org-roam”.  Instead the attempt of patch#50374 is to 
>> install with
>> “guix install emacs-org-roam-extensions”.  Well, I do not know 
>> if
>> patch#50374 is correct, though.
>>
>> Because I am not an Org-Roam user, I do not have an opinion 
>> about this
>> extensions.  Maybe it is better to distribute them along the 
>> package
>> emacs-org-roam or in a separate package, I do not know.  WDYT?
>
> I mean, structurally the upstream owner just moved some files to a 
> new
> folder, my guess is that it shouldn't be a different packages 
> since it
> is still part of org-roam.

Note that some packages are only one upstream source but indeed
different packages.  For instance, notmuch and emacs-notmuch (for the
most recent :-)).  Another example, IIRC, some time ago, Org-contrib was
a folder under Org but distributed by 2 packages.  Well, it is sometime
the same package and simply that upstream reorganize stuff. :-)

BTW, why is it needed to explicitly copy the “extensions” files?
Without this added phase, does it not work?

All the best,
simon
diff mbox series

Patch

From a99fa75c0f5d3025827d99c3ef6a2c71c85e0be5 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Adolfo=20De=20Un=C3=A1nue?= <adolfo+git@unanue.mx>
Date: Thu, 2 Sep 2021 22:23:58 -0500
Subject: [PATCH] Fixed missing files in org-roam v2.1.0

---
 gnu/packages/emacs-xyz.scm | 94 +++++++++++++++++++++-----------------
 1 file changed, 53 insertions(+), 41 deletions(-)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 030809f5ac..431444c255 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -103,6 +103,7 @@ 
 ;;; Copyright © 2021 Matthew James Kraai <kraai@ftbfs.org>
 ;;; Copyright © 2021 Noisytoot <noisytoot@disroot.org>
 ;;; Copyright © 2021 Simon South <simon@simonsouth.net>
+;;; Copyright © 2021 Nanounanue <adolfo@unanue.mx>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -28219,51 +28220,62 @@  snippets for Emacs.")
       (license license:expat))))
 
 (define-public emacs-org-roam
-  (package
-    (name "emacs-org-roam")
-    (version "2.1.0")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/org-roam/org-roam")
-             (commit (string-append "v" version))))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32 "092xn0sqc7b7f6pdf7m6c3giqqbh6fq02mfz8qrg0wmx4ds1isqp"))))
-    (build-system emacs-build-system)
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-after 'install 'install-image
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let ((out (assoc-ref outputs "out")))
-               (install-file "doc/images/org-ref-citelink.png"
-                             (string-append out "/share/info/images")))))
-         (add-after 'install-image 'make-info
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let ((out (assoc-ref outputs "out")))
-               (with-directory-excursion "doc"
-                 (invoke "makeinfo" "-o" "org-roam.info" "org-roam.texi")
-                 (install-file "org-roam.info"
-                               (string-append out "/share/info")))))))))
-       (native-inputs
-        `(("texinfo" ,texinfo)))
-       (propagated-inputs
-        `(("emacs-dash" ,emacs-dash)
-          ("emacs-emacsql-sqlite3" ,emacs-emacsql-sqlite3)
-          ("emacs-f" ,emacs-f)
-          ("emacs-magit" ,emacs-magit)
-          ("emacs-org" ,emacs-org)
-          ("emacs-s" ,emacs-s)))
-       (home-page "https://github.com/org-roam/org-roam/")
-       (synopsis "Non-hierarchical note-taking with Org mode")
-       (description "Emacs Org Roam is a solution for taking non-hierarchical
+  (let ((commit "f819720c510185af713522c592833ec9f2934251")
+        (revision "1"))
+    (package
+      (name "emacs-org-roam")
+      (version (git-version "2.1.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/org-roam/org-roam")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "092xn0sqc7b7f6pdf7m6c3giqqbh6fq02mfz8qrg0wmx4ds1isqp"))))
+      (build-system emacs-build-system)
+      (arguments
+       `(#:phases
+         (modify-phases %standard-phases
+           (add-after 'install 'install-image
+             (lambda* (#:key outputs #:allow-other-keys)
+               (let ((out (assoc-ref outputs "out")))
+                 (install-file "doc/images/org-ref-citelink.png"
+                               (string-append out "/share/info/images")))))
+           (add-after 'install 'install-extensions
+             (lambda* (#:key outputs #:allow-other-keys)
+               (copy-recursively
+                "extensions"
+                (string-append (assoc-ref outputs "out")
+                               (string-append
+                                "/share/emacs/site-lisp/org-roam-"
+                                ,version)))
+               #t))
+           (add-after 'install-image 'make-info
+             (lambda* (#:key outputs #:allow-other-keys)
+               (let ((out (assoc-ref outputs "out")))
+                 (with-directory-excursion "doc"
+                   (invoke "makeinfo" "-o" "org-roam.info" "org-roam.texi")
+                   (install-file "org-roam.info"
+                                 (string-append out "/share/info")))))))))
+      (native-inputs
+       `(("texinfo" ,texinfo)))
+      (propagated-inputs
+       `(("emacs-dash" ,emacs-dash)
+         ("emacs-emacsql-sqlite3" ,emacs-emacsql-sqlite3)
+         ("emacs-f" ,emacs-f)
+         ("emacs-magit" ,emacs-magit)
+         ("emacs-org" ,emacs-org)
+         ("emacs-s" ,emacs-s)))
+      (home-page "https://github.com/org-roam/org-roam/")
+      (synopsis "Non-hierarchical note-taking with Org mode")
+      (description "Emacs Org Roam is a solution for taking non-hierarchical
 notes with Org mode.  Notes are captured without hierarchy and are connected
 by tags.  Notes can be found and created quickly.  Org Roam should also work
 as a plug-and-play solution for anyone already using Org mode for their
 personal wiki.")
-       (license license:gpl3+)))
+      (license license:gpl3+))))
 
 (define-public emacs-org-roam-bibtex
   (package
-- 
2.33.0