diff mbox series

[bug#53727] gnu: Add emacs-nano-modeline

Message ID 87v8xxtduh.fsf@posteo.net
State Accepted
Headers show
Series [bug#53727] gnu: Add emacs-nano-modeline | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Niklas Eklund Feb. 2, 2022, 4:47 p.m. UTC
Hello,

this patch adds the emacs-nano-modeline package.

/Niklas

Comments

Nicolas Goaziou Feb. 6, 2022, 10:03 p.m. UTC | #1
Hello,

Niklas Eklund <niklas.eklund@posteo.net> writes:

> +(define-public emacs-nano-modeline
> +  ;; No tagged release upstream, this commit is a couple of commits newer than 0.5
> +  ;; because of an error related to make-obsolete-variable
> +  (let ((commit "c5bf2a977f1a06936ceb7a1805d1e2cf1f92f616")
> +        (revision "0"))

Applied. Thank you.

> +      (synopsis "GNU Emacs / N Λ N O Modeline")
> +      (description "Nano modeline is a minor mode for GNU/Emacs.")

I tried to make synopsis and description more informative.

Regards,
diff mbox series

Patch

From 104b89a64cf8b88282a315d0b4af3310a7e2619c Mon Sep 17 00:00:00 2001
From: Niklas Eklund <niklas.eklund@posteo.net>
Date: Wed, 2 Feb 2022 17:42:33 +0100
Subject: [PATCH] gnu: Add emacs-nano-modeline.

* gnu/packages/emacs-xyz.scm (emacs-nano-modeline): New variable.
---
 gnu/packages/emacs-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index b88302d967..46dac82501 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -997,6 +997,29 @@  (define-public emacs-minions
 @code{(global-set-key [S-down-mouse-3] 'minions-minor-modes-menu)}.")
     (license license:gpl3+)))
 
+(define-public emacs-nano-modeline
+  ;; No tagged release upstream, this commit is a couple of commits newer than 0.5
+  ;; because of an error related to make-obsolete-variable
+  (let ((commit "c5bf2a977f1a06936ceb7a1805d1e2cf1f92f616")
+        (revision "0"))
+    (package
+      (name "emacs-nano-modeline")
+      (version (git-version "0.5" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/rougier/nano-modeline")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "02c38v9a71wc9p10pjnqymyaqk4sf3nc5i7df1j9qr5qrqwniq89"))))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/rougier/nano-modeline")
+      (synopsis "GNU Emacs / N Λ N O Modeline")
+      (description "Nano modeline is a minor mode for GNU/Emacs.")
+      (license license:gpl3+))))
+
 (define-public emacs-moody
   (package
     (name "emacs-moody")
-- 
2.34.0