diff mbox series

[bug#55929] gnu: maven: Add maven-doxia-sink-api

Message ID 87v8sx45hr.fsf@gmail.com
State Accepted
Headers show
Series [bug#55929] gnu: maven: Add maven-doxia-sink-api | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Artyom V. Poptsov June 19, 2022, 4:55 a.m. UTC
Hello Julien,

thanks for help.  I think I'm beginning to better understand the
child/parent POM relationships now.

Here's the updated patch.
- Artyom

Comments

Julien Lepiller June 19, 2022, 7:03 p.m. UTC | #1
Le Sun, 19 Jun 2022 07:55:12 +0300,
"Artyom V. Poptsov" <poptsov.artyom@gmail.com> a écrit :

> Hello Julien,
> 
> thanks for help.  I think I'm beginning to better understand the
> child/parent POM relationships now.
> 
> Here's the updated patch.
> 

Thanks, pushed to master as 0d461393e444a993a469b521d4cf46dee9e2767e. I
changed the commit message to add a dot at the end of the first
sentence. I added maven-parent-pom-34 as a propagated-input to
maven-doxia-parent-pom, and removed java-javax-inject from
maven-doxia-sink-api because it's not needed.
diff mbox series

Patch

From 90515d2a565b0b840cb67303672df928a1c16eb5 Mon Sep 17 00:00:00 2001
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Sun, 12 Jun 2022 21:42:33 +0300
Subject: [PATCH] gnu: Add maven-doxia-sink-api

* gnu/packages/maven.scm (maven-doxia-sink-api): New variable.
  (maven-doxia-parent-pom): New private variable.
---
 gnu/packages/maven.scm | 52 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 52 insertions(+)

diff --git a/gnu/packages/maven.scm b/gnu/packages/maven.scm
index 817fee1c71..ace8de684e 100644
--- a/gnu/packages/maven.scm
+++ b/gnu/packages/maven.scm
@@ -3,6 +3,7 @@ 
 ;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2019 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
 ;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2022 Artyom V. Poptsov <poptsov.artyom@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -3887,3 +3888,54 @@  reports in two different file formats, plain text and xml.")))
     (description "This plugin provides the capability to build jars.  If you
 would like to sign jars please use the Maven Jarsigner Plugin instead.")
     (license license:asl2.0)))
+
+(define-public maven-doxia-sink-api
+  (package
+    (name "maven-doxia-sink-api")
+    (version "2.0.0-M2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://gitbox.apache.org/repos/asf/maven-doxia.git")
+                    (commit (string-append "doxia-" version))))
+              (file-name (git-file-name "doxia" version))
+              (sha256
+               (base32
+                "0jx96lg0hgjsrm8mynhac4hwh2hmgiwjpwpx2k03yr14040zcr48"))))
+    (build-system ant-build-system)
+    (native-inputs
+     (list java-javax-inject))
+    (propagated-inputs
+     (list maven-doxia-parent-pom))
+    (arguments
+     `(#:jar-name "doxia-sink-api.jar"
+       #:source-dir "doxia-sink-api/src/main/java"
+       #:tests? #f ; no tests
+       #:phases (modify-phases %standard-phases
+                  (replace 'install
+                    (install-from-pom "doxia-sink-api/pom.xml")))))
+    (home-page "https://maven.apache.org/doxia/index.html")
+    (synopsis "Generic markup language interface")
+    (description
+     "The @code{Sink} interface is a generic markup language
+interface provided as a Java API.  It contains several methods that
+encapsulate common text syntax.  A start tag is denoted by @code{xxxx()}
+method and a end of tag by @code{xxxx_()} method.")
+    (license license:asl2.0)))
+
+(define maven-doxia-parent-pom
+  (package
+    (inherit maven-doxia-sink-api)
+    (name "maven-doxia-parent-pom")
+    (arguments
+     `(#:tests? #f
+       #:phases (modify-phases %standard-phases
+                  (delete 'configure)
+                  (delete 'build)
+                  (replace 'install
+                    (install-pom-file "pom.xml")))))
+    (propagated-inputs '())
+    (synopsis "Content generation framework")
+    (description "\"Doxia\" is a content generation framework that provides
+powerful techniques for generating static and dynamic content, supporting a
+variety of markup languages.")))
-- 
2.25.1