diff mbox series

[bug#55908] gnu: Add python-spacy-loggers

Message ID 87v8seixxu.fsf@gmail.com
State New
Headers show
Series [bug#55908] gnu: Add python-spacy-loggers | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Artyom V. Poptsov July 3, 2022, 5:10 a.m. UTC
Hello,

this is an updated version of the patch that is rebased on 'master' and
with some style fixes.
- Artyom
diff mbox series

Patch

From 5a732b5f6afeef9dc75848d6afa8334048601ff7 Mon Sep 17 00:00:00 2001
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Sat, 11 Jun 2022 16:43:36 +0300
Subject: [PATCH] gnu: Add python-spacy-loggers.

* gnu/packages/python-xyz.scm (python-spacy-loggers): New variable.
---
 gnu/packages/python-xyz.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1d43049776..a63392036e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -30006,3 +30006,32 @@  (define-public python-langcodes
 and names, built from Unicode CLDR and the IANA subtag registry, if you
 install @code{python-language-data}.")
     (license license:expat)))
+
+(define-public python-spacy-loggers
+  (package
+    (name "python-spacy-loggers")
+    (version "1.0.2")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "spacy-loggers" version))
+              (sha256
+               (base32
+                "0vjk2cnfl94yxg48p81209wr42hf8a67rjijf4ypdrlrrzs48pg7"))))
+    (build-system python-build-system)
+    (inputs (list python-wasabi))
+    (arguments
+     (list #:tests? #f)) ; It needs spaCy itself to run the tests.
+    (home-page "https://github.com/explosion/spacy-loggers")
+    (synopsis "Logging utilities for @code{python-spacy}")
+    (description
+     "Starting with @code{python-spacy} v3.2, alternate loggers
+are moved into a separate package so that they can be added and updated
+independently from the core spaCy library.
+
+spacy-loggers currently provides loggers for:
+@itemize
+@item Weights & Biases
+@item MLflow
+@end itemize
+")
+    (license license:expat)))
-- 
2.34.1