diff mbox series

[bug#57632] : Update sbcl-list-unit2 to 0.9.3

Message ID 87v8q0uu7g.fsf@gmail.com
State Accepted
Headers show
Series [bug#57632] : Update sbcl-list-unit2 to 0.9.3 | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

André A. Gomes Sept. 6, 2022, 8:24 p.m. UTC
Hi Guix,

Please find the patch attached.  Thanks.

Comments

Guillaume Le Vaillant Sept. 7, 2022, 12:41 p.m. UTC | #1
Patch pushed as c02450c2373ad8b60b93a67bab6891b4321e34b3.
Thanks.
diff mbox series

Patch

From d6826ad7c203ab1a1bb42f9837ece3fc0721f223 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Andr=C3=A9=20A=2E=20Gomes?= <andremegafone@gmail.com>
Date: Tue, 6 Sep 2022 23:22:42 +0300
Subject: [PATCH] gnu: sbcl-lisp-unit2: Update to 0.9.3.

* gnu/packages/lisp-xyz.scm (sbcl-lisp-unit2): Update to 0.9.3.
---
 gnu/packages/lisp-check.scm | 46 ++++++++++++++++++-------------------
 1 file changed, 22 insertions(+), 24 deletions(-)

diff --git a/gnu/packages/lisp-check.scm b/gnu/packages/lisp-check.scm
index 8c850ee850..bd1a661d4b 100644
--- a/gnu/packages/lisp-check.scm
+++ b/gnu/packages/lisp-check.scm
@@ -542,32 +542,30 @@  (define-public ecl-lisp-unit
 (define-public sbcl-lisp-unit2
   ;; There is a cyclical dependency between symbol-munger and lisp-unit2.
   ;; See https://github.com/AccelerationNet/symbol-munger/issues/4
-  (let ((commit "fb9721524d1e4e73abb223ee036d74ce14a5505c")
-        (revision "1"))
-    (package
-      (name "sbcl-lisp-unit2")
-      (version (git-version "0.2.0" revision commit))
-      (source
-       (origin
-         (method git-fetch)
-         (uri (git-reference
-               (url "https://github.com/AccelerationNet/lisp-unit2")
-               (commit commit)))
-         (file-name (git-file-name name version))
-         (sha256
-          (base32
-           "1rsqy8y0jqll6xn9a593848f5wvd5ribv4csry1ly0hmdhfnqzlp"))))
-      (build-system asdf-build-system/sbcl)
-      (inputs
-       (list sbcl-alexandria sbcl-cl-interpol sbcl-iterate
-             sbcl-symbol-munger))
-      (synopsis "Test Framework for Common Lisp")
-      (description
-       "LISP-UNIT2 is a Common Lisp library that supports unit testing in the
+  (package
+    (name "sbcl-lisp-unit2")
+    (version "0.9.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/AccelerationNet/lisp-unit2")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "0y7k6fd4mf7ggc8kdrbg8flkj5j7i7ki1350wnj6hqax7cmh4xv5"))))
+    (build-system asdf-build-system/sbcl)
+    (inputs
+     (list sbcl-alexandria sbcl-cl-interpol sbcl-iterate
+           sbcl-symbol-munger))
+    (synopsis "Test Framework for Common Lisp")
+    (description
+     "LISP-UNIT2 is a Common Lisp library that supports unit testing in the
 style of JUnit for Java.  It is a new version of the lisp-unit library written
 by Chris Riesbeck.")
-      (home-page "https://github.com/AccelerationNet/lisp-unit2")
-      (license license:expat))))
+    (home-page "https://github.com/AccelerationNet/lisp-unit2")
+    (license license:expat)))
 
 (define-public cl-lisp-unit2
   (sbcl-package->cl-source-package sbcl-lisp-unit2))
-- 
2.37.2