diff mbox series

[bug#66143] : Update emacs-slime and sbcl-slime-swank to 2.28-0.1e4b741

Message ID 87v8awa32o.fsf@gmail.com
State New
Headers show
Series [bug#66143] : Update emacs-slime and sbcl-slime-swank to 2.28-0.1e4b741 | expand

Commit Message

André A. Gomes Oct. 24, 2023, 7:31 a.m. UTC
Guillaume Le Vaillant <glv@posteo.net> writes:

> Hi.
> Concerning patch 2 for sbcl-slime-swank, the first 'substitute*' form
> of the 'set-fasl-directory' phase looks obsolete because of changes in
> "swank.asd".
> If the fasl files are now put in the right place even without it, and if
> slime and swank still work fine, could you send an updated patch?
> Thanks.

Hi Guillaume,

Thanks for pointing that out.  Please find the updated patches attached.

Comments

Guillaume Le Vaillant Oct. 24, 2023, 12:40 p.m. UTC | #1
Patches applied as d62a613bcff726dfc835313064228e7bc3b7cda6 and
following, with a completed commit message for the second patch.
Thanks.
Christopher Baines Oct. 24, 2023, 1:08 p.m. UTC | #2
Guillaume Le Vaillant <glv@posteo.net> writes:

> Patches applied as d62a613bcff726dfc835313064228e7bc3b7cda6 and
> following, with a completed commit message for the second patch.

I did raise an objection earlier in the thread to these changes being
merged. Not discussing (or even acknowledging issues raised) is
unhelpful.

Given what I've now read from upstream [1], I think it can be justified
in this case, but this is independent from the above. I think we still
should record reasons for deviating from the norm in comments (and
commit messages if useful).

1: https://github.com/slime/slime/issues/792
diff mbox series

Patch

From ef9e74ddf74fb336748529ce6bcc508ef245712c Mon Sep 17 00:00:00 2001
From: "Andre A. Gomes" <andremegafone@gmail.com>
Date: Tue, 24 Oct 2023 10:28:43 +0300
Subject: [PATCH 2/2] gnu: sbcl-slime-swank: Update to 2.28-0.0cc2e73.

* gnu/packages/lisp-xyz.scm (sbcl-slime-swank): Update to 2.28-0.0cc2e73.
---
 gnu/packages/lisp-xyz.scm | 83 ++++++++++++++-------------------------
 1 file changed, 29 insertions(+), 54 deletions(-)

diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index e7b603f59d..692142e4a8 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -3610,76 +3610,51 @@  (define-public ecl-pythonic-string-reader
   (sbcl-package->ecl-package sbcl-pythonic-string-reader))
 
 (define-public sbcl-slime-swank
-  (package
-    (name "sbcl-slime-swank")
-    (version "2.28")
-    (source
-     (origin
-       (file-name (git-file-name "cl-slime-swank" version))
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/slime/slime/")
-             (commit (string-append "v" version))))
-       (sha256
-        (base32 "1acmm4w1mv1qzpnkgc4wyiilbx8l0dk16sx8wv815ri5ks289rll"))
-       (modules '((guix build utils)))
+  (let ((commit "0cc2e736112a0bc2a048ef6efd11dd67e3fbf7ad")
+        (revision "0"))
+    (package
+      (name "sbcl-slime-swank")
+      (version (git-version "2.28" revision commit))
+      (source
+       (origin
+         (file-name (git-file-name "cl-slime-swank" version))
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/slime/slime/")
+               (commit commit)))
+         (sha256
+          (base32 "0iq9r4007rrnabj290y79i926x2m4j20j6b0x701pkywz926sn02"))
+         (modules '((guix build utils)))
          (snippet
           ;; The doc folder drags `gawk' into the closure.  Doc is already
           ;; provided by emacs-slime.
           `(begin
              (delete-file-recursively "doc")
              #t))))
-    (build-system asdf-build-system/sbcl)
-    (arguments
-     '(#:asd-systems '("swank")
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'set-fasl-directory
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let* ((out (assoc-ref outputs "out"))
-                    (lib-dir (string-append out "/lib/common-lisp/"
-                                            (%lisp-type)
-                                            "/slime-swank/")))
-               ;; Use the ASDF registry instead of Swank's default that places
-               ;; the .fasl files in ~/.slime.
-               (substitute* "swank.asd"
-                 (("\\(load \\(asdf::component-pathname f\\)\\)" all)
-                  (string-append
-                   all "\n"
-                   "(setf (symbol-value"
-                   "(read-from-string \"swank-loader::*fasl-directory*\"))"
-                   "\"" lib-dir "\")")))
+      (build-system asdf-build-system/sbcl)
+      (arguments
+       '(#:asd-systems '("swank" "swank/exts")
+         #:phases
+         (modify-phases %standard-phases
+           (add-after 'unpack 'set-fasl-directory
+             (lambda* (#:key outputs #:allow-other-keys)
                (substitute* "swank-loader.lisp"
                  (("\\(probe-file fasl\\)" all)
                   ;; Do not try to delete Guix store files.
                   (string-append
                    all "\n"
                    " (not (equal (subseq (pathname-directory fasl) 1 3)"
-                   " '(\"gnu\" \"store\"))) ; XXX: GUIX PATCH")))))))))
-    (home-page "https://github.com/slime/slime")
-    (synopsis "Common Lisp Swank server")
-    (description
-     "This is only useful if you want to start a Swank server in a Lisp
+                   " '(\"gnu\" \"store\"))) ; XXX: GUIX PATCH"))))))))
+      (home-page "https://github.com/slime/slime")
+      (synopsis "Common Lisp Swank server")
+      (description
+       "This is only useful if you want to start a Swank server in a Lisp
 processes that doesn't run under Emacs.  Lisp processes created by
 @command{M-x slime} automatically start the server.")
-    (license (list license:gpl2+ license:public-domain))))
+      (license (list license:gpl2+ license:public-domain)))))
 
 (define-public cl-slime-swank
-  (let ((pkg (sbcl-package->cl-source-package sbcl-slime-swank)))
-    (package
-      (inherit pkg)
-      (arguments
-       (substitute-keyword-arguments (package-arguments pkg)
-         ((#:phases phases)
-          `(modify-phases ,phases
-             (add-after 'install 'revert-asd-patch
-               ;; We do not want to include the Guix patch in the cl- package
-               ;; since it would include the sbcl- package in the closure.
-               (lambda* (#:key outputs #:allow-other-keys)
-                 (let* ((out (assoc-ref outputs "out"))
-                        (source-path (string-append out "/share/common-lisp/source/")))
-                   (substitute* (string-append source-path "/cl-slime-swank/swank.asd")
-                     ((".*fasl-directory.*") ""))))))))))))
+  (sbcl-package->cl-source-package sbcl-slime-swank))
 
 (define-public ecl-slime-swank
   (sbcl-package->ecl-package sbcl-slime-swank))
-- 
2.41.0