diff mbox series

bug#66535: [PATCH] gnu: Add emacs-pacfiles-mode.

Message ID 87v8aw57lc.fsf@gnu.org
State New
Headers show
Series bug#66535: [PATCH] gnu: Add emacs-pacfiles-mode. | expand

Commit Message

Ludovic Courtès Oct. 24, 2023, 4:05 p.m. UTC
Hi,

Cayetano Santos <csantosb@inventati.org> skribis:

> * gnu/packages/emacs-xyz.scm (emacs-pacfiles-mode): New variable.

Applied with the changes below, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 497efbea58..2784ae2ef2 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -1737,17 +1737,18 @@  (define-public emacs-pacfiles-mode
     (source (origin
               (method git-fetch)
               (uri (git-reference
-                    (url "https://github.com/UndeadKernel/pacfiles-mode.git")
+                    (url "https://github.com/UndeadKernel/pacfiles-mode")
                     (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
               (sha256
                (base32
                 "1d61s846r9ncmyx97f44r8i3p1ikgi4bab8k7xk868lja96y2ij7"))))
     (build-system emacs-build-system)
     (home-page "https://github.com/UndeadKernel/pacfiles-mode")
-    (synopsis "Archlinux’s pacnew and pacsave merging tool")
+    (synopsis "ArchLinux's pacnew and pacsave merging tool")
     (description
-     "Emacs major mode to manage .pacnew and .pacsave files left by
-  ArchLinux's pacman")
+     "This Emacs major mode helps manage @file{.pacnew} and @file{.pacsave}
+files left by ArchLinux's pacman.")
     (license license:expat)))
 
 (define-public emacs-minions