diff mbox series

[bug#66811] gnu: Deprecate the "go-github-com-lucas-clemente-quic-go" variable.

Message ID 87v8apiz5q.fsf@gmail.com
State New
Headers show
Series [bug#66811] gnu: Deprecate the "go-github-com-lucas-clemente-quic-go" variable. | expand

Commit Message

Artyom V. Poptsov Oct. 29, 2023, 8:57 a.m. UTC
Hello,

this patch renames "go-github-com-lucas-clemente-quic-go" to
"go-github-com-quic-go-quic-go" to match the upstream. [1]
Thanks,

- avp

References:
1. https://github.com/quic-go/quic-go

Comments

Sharlatan Hellseher Jan. 24, 2024, 12:46 p.m. UTC | #1
Hi,

--8<---------------cut here---------------start------------->8---
+       #:tests? #f
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'fix-repository-path
+           (lambda _
+             (substitute* (find-files "src/github.com/quic-go/quic-go/" ".*\\.go|.*\\.mod")
+               (("lucas-clemente")
+                "quic-go")))))))
--8<---------------cut here---------------end--------------->8---

Did you try to build the packe with #:unpack-path?

Something like this:
--8<---------------cut here---------------start------------->8---
     (arguments
     '(#:import-path "github.com/quic-go/quic-go"
       #:unpack-path "github.com/quic-go/quic-go"
--8<---------------cut here---------------end--------------->8---

Thanks,
Oleg
Sharlatan Hellseher April 6, 2024, 10:17 p.m. UTC | #2
Closing as it was pushed as 3634c55ce48a73a5b728f74a3e890ba3f9b43bcb to master.

--
Oleg
diff mbox series

Patch

From 9052b1e875a5bebbb969d15c7b1bed4d62f93260 Mon Sep 17 00:00:00 2001
Message-ID: <9052b1e875a5bebbb969d15c7b1bed4d62f93260.1698569698.git.poptsov.artyom@gmail.com>
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Sun, 29 Oct 2023 11:54:49 +0300
Subject: [PATCH] gnu: Deprecate the "go-github-com-lucas-clemente-quic-go"
 variable.

* gnu/packages/golang.scm (go-github-com-lucas-clemente-quic-go): Rename to
  "go-github-com-quic-go-quic-go".
  [arguments]: Patch source files to replace "lucas-clemente" with "quic-go".
  [home-page]: Update.
  (go-github-com-lucas-clemente-quic-go): Define as deprecated by
  "go-github-com-quic-go-quic-go".

Change-Id: I9a99d4d904fadcf0b6854e806042ce5ad190ac0c
---
 gnu/packages/golang.scm | 25 ++++++++++++++++++-------
 1 file changed, 18 insertions(+), 7 deletions(-)

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index b32e379e47..e629c9c935 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7691,14 +7691,14 @@  (define-public go-github-com-cheekybits-genny
     (home-page "https://github.com/cheekybits/genny/")
     (license license:expat)))
 
-(define-public go-github-com-lucas-clemente-quic-go
+(define-public go-github-com-quic-go-quic-go
   (package
-    (name "go-github-com-lucas-clemente-quic-go")
+    (name "go-github-com-quic-go-quic-go")
     (version "0.14.4")
     (source (origin
               (method git-fetch)
               (uri (git-reference
-                     (url "https://github.com/lucas-clemente/quic-go")
+                     (url "https://github.com/quic-go/quic-go")
                      (commit (string-append "v" version))))
               (file-name (git-file-name name version))
               (sha256
@@ -7706,20 +7706,31 @@  (define-public go-github-com-lucas-clemente-quic-go
                 "04l3gqbc3gh079n8vgnrsf8ypgv8sl63xjf28jqfrb45v2l73vyz"))))
     (build-system go-build-system)
     (arguments
-     '(#:import-path "github.com/lucas-clemente/quic-go"
+     '(#:import-path "github.com/quic-go/quic-go"
        ;; XXX More packages required...
-       #:tests? #f))
+       #:tests? #f
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'fix-repository-path
+           (lambda _
+             (substitute* (find-files "src/github.com/quic-go/quic-go/" ".*\\.go|.*\\.mod")
+               (("lucas-clemente")
+                "quic-go")))))))
     (propagated-inputs
-     (list go-golang-org-x-crypto go-github-com-cheekybits-genny
+     (list go-golang-org-x-crypto
+           go-github-com-cheekybits-genny
            go-github-com-marten-seemann-chacha20
            go-github-com-marten-seemann-qtls
            go-github-com-golang-protobuf-proto))
     (synopsis "QUIC in Go")
     (description "This package provides a Go language implementation of the QUIC
 network protocol.")
-    (home-page "https://github.com/lucas-clemente/quic-go")
+    (home-page "https://github.com/quic-go/quic-go")
     (license license:expat)))
 
+(define-public go-github-com-lucas-clemente-quic-go
+  (deprecated-package "go-github-com-lucas-clemente-quic-go" go-github-com-quic-go-quic-go))
+
 (define-public go-github-com-lunixbochs-vtclean
   (package
     (name "go-github-com-lunixbochs-vtclean")

base-commit: 2b5c6e1a41e4ddcf4cfa53a319ed784a856eac5d
-- 
2.41.0