diff mbox series

[bug#68153] gnu: Add python-find-libpython.

Message ID 87v88ey5it.fsf@troyfigiel.com
State New
Headers show
Series [bug#68153] gnu: Add python-find-libpython. | expand

Commit Message

Troy Figiel Dec. 31, 2023, 11:14 a.m. UTC
* gnu/packages/python-xyz.scm (python-find-libpython): New variable.
---
 gnu/packages/python-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)


base-commit: 2a242e86379ebddbdddf2927f26e5e27a98fc605
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2afce6c667..c4bbe14a7c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -9159,6 +9159,30 @@  (define-public python-executor
 particularly the AST node being executed.")
     (license license:expat))) ; MIT license
 
+(define-public python-find-libpython
+  (package
+    (name "python-find-libpython")
+    (version "0.3.1")
+    (source
+     (origin
+       ;; Only available as a binary release on PyPI.
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/ktbarrett/find_libpython")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "1d7y9srf5j8g34azf0j1jnnrn5al55cnzb4kkx2l1q8hys0l040c"))))
+    (build-system pyproject-build-system)
+    (native-inputs (list python-pytest))
+    (home-page "https://github.com/ktbarrett/find_libpython")
+    (synopsis "Find the path to the @code{libpython} dynamic library")
+    (description "@code{find_libpython} helps find the path to the
+@code{libpython} dynamic library for the current Python environment.  It is
+both a script and a Python package.")
+    (license license:expat))) ; MIT license
+
 (define-public python-roifile
   (package
     (name "python-roifile")